aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/ghostscript5/Makefile')
-rw-r--r--print/ghostscript5/Makefile44
1 files changed, 24 insertions, 20 deletions
diff --git a/print/ghostscript5/Makefile b/print/ghostscript5/Makefile
index d75e7959e2d8..00412ff5a02c 100644
--- a/print/ghostscript5/Makefile
+++ b/print/ghostscript5/Makefile
@@ -8,16 +8,15 @@
DISTNAME= ghostscript-5.10
CATEGORIES= print
-MASTER_SITES= ftp://ftp.pdb.sni.de/pub/utilities/misc/ \
- http://www.ozemail.com.au/~geoffk/pdfencrypt/ \
- ftp://ftp.cs.wisc.edu/ghost/gnu/gs510/ \
- $(MASTER_SITE_GNU)
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ ftp://ftp.cs.wisc.edu/ghost/gnu/gs510/ \
+ ftp://ftp.pdb.sni.de/pub/utilities/misc/
MASTER_SITE_SUBDIR= ghostscript
-DISTFILES= ${PCL3_DRV} ${DECRYPT_PDF} ghostscript-5.10.tar.gz
+DISTFILES= ${GS_SOURCES} ${PCL3_DRV}
MAINTAINER= ports@FreeBSD.org
-RUN_DEPENDS= $(LOCALBASE)/share/ghostscript/fonts/Fontmap:${PORTSDIR}/print/gsfonts
+RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/Fontmap:${PORTSDIR}/print/gsfonts
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract \
/nonexistent:${PORTSDIR}/graphics/png:extract
LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png
@@ -35,27 +34,32 @@ GS_SOURCES= ghostscript-5.10.tar.gz
# Additional driver for HP PCL3 Printers
PCL3_DRV= hpdj-2.5.tar.gz
-# replacement for pdf_sec.ps, that allows you to read encrypted PDF files
-DECRYPT_PDF= pdf_sec.ps
-
post-extract:
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng-1.0.3 ${WRKSRC}/libpng
# additional PCL3 driver
- $(TAR) -xvf ${WRKDIR}/hpdj-2.5/hpdj.tar -C $(WRKSRC)
- ${PATCH} --directory=${WRKSRC} <${WRKSRC}/devs.mak-5.10.diff
- ${PATCH} --directory=${WRKSRC} <${WRKSRC}/zmedia2.c-5.10.diff
+ @${TAR} -xf ${WRKDIR}/hpdj-2.5/hpdj.tar -C ${WRKSRC}
+ @${PATCH} -d ${WRKSRC} --forward --quiet -E < ${WRKSRC}/devs.mak-5.10.diff
+ @${PATCH} -d ${WRKSRC} --forward --quiet -E < ${WRKSRC}/zmedia2.c-5.10.diff
do-configure:
- @(cd ${WRKSRC}; /bin/sh tar_cat )
+ @(cd ${WRKSRC}; ${SH} tar_cat )
post-install:
- strip ${PREFIX}/bin/gs
- ${INSTALL_DATA} ${DISTDIR}/${DECRYPT_PDF} \
- ${PREFIX}/share/ghostscript/5.10
- $(MKDIR) ${PREFIX}/libexec/lpr
- ${INSTALL_SCRIPT} $(WRKSRC)/pj-gs.sh ${PREFIX}/libexec/lpr
- ${INSTALL_SCRIPT} $(WRKSRC)/sysvlp.sh ${PREFIX}/libexec/lpr
- ${INSTALL_SCRIPT} $(WRKSRC)/if-hpdj ${PREFIX}/libexec/lpr
+ @strip ${PREFIX}/bin/gs
+ @${MKDIR} ${PREFIX}/libexec/lpr
+ ${INSTALL_SCRIPT} ${WRKSRC}/pj-gs.sh ${PREFIX}/libexec/lpr
+ ${INSTALL_SCRIPT} ${WRKSRC}/sysvlp.sh ${PREFIX}/libexec/lpr
+ ${INSTALL_SCRIPT} ${WRKSRC}/if-hpdj ${PREFIX}/libexec/lpr
+.if defined(PDFENCRYPT)
+ ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps ${PREFIX}/share/ghostscript/5.10
+.endif
+
+# encrypted PDF support. can't be packaged due to export control issues.
+.if defined(PDFENCRYPT)
+MASTER_SITES+= http://www.ozemail.com.au/~geoffk/pdfencrypt/
+DISTFILES+= pdf_sec.ps
+RESTRICTED= "Crypto; export controlled, RC4 in PostScript code included"
+.endif
.include <bsd.port.mk>