aboutsummaryrefslogtreecommitdiffstats
path: root/www/twhttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/twhttpd/Makefile')
-rw-r--r--www/twhttpd/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/www/twhttpd/Makefile b/www/twhttpd/Makefile
index 194862a14472..8454ff674ee6 100644
--- a/www/twhttpd/Makefile
+++ b/www/twhttpd/Makefile
@@ -6,23 +6,25 @@
#
PORTNAME= twhttpd
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.01
CATEGORIES= www
MASTER_SITES= http://www.geocities.com/samngms/twhttpd/download/
-DISTNAME= twhttpd-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Secure HTTP Proxy
-GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:213
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-lmd"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
+ @${REINPLACE_CMD} -e 's| md5\.o | |g' ${WRKSRC}/Makefile.in
do-install:
- @${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
- @${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
- @${INSTALL} -o root -g wheel -m 0700 ${WRKSRC}/twhttpd.cfg ${PREFIX}/etc/twhttpd.cfg.sample
+ ${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
+ ${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
+ ${INSTALL} -o root -g wheel -m 0700 ${WRKSRC}/twhttpd.cfg ${PREFIX}/etc/twhttpd.cfg.sample
post-install:
@${CAT} ${PKGMESSAGE}