aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gtk-cleanice-engine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gtk-cleanice-engine/Makefile')
-rw-r--r--x11-toolkits/gtk-cleanice-engine/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/x11-toolkits/gtk-cleanice-engine/Makefile b/x11-toolkits/gtk-cleanice-engine/Makefile
index 6f61b6678818..368b355f41a9 100644
--- a/x11-toolkits/gtk-cleanice-engine/Makefile
+++ b/x11-toolkits/gtk-cleanice-engine/Makefile
@@ -6,17 +6,35 @@
#
PORTNAME= gtk-cleanice-engine
-PORTVERSION= 1.2.7
+PORTVERSION= 1.2.8
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= elysium-project
-DISTNAME= cleanice-theme-${PORTVERSION}
+DISTNAME= gtk-engines-cleanice-${PORTVERSION}
+DISTFILES= ${DISTNAME}.tar.gz \
+ ${THEME}.tar.gz
-MAINTAINER= philip@paeps.cx
+MAINTAINER= philip@FreeBSD.org
COMMENT= A simplistic GTK+ 2.x theme engine
USE_X_PREFIX= yes
USE_LIBTOOL= yes
USE_GNOME= gnomehack gtk20
+THEME= cleanice-theme-1.2.7
+THEMEDIR= ${WRKDIR}/${THEME}/Theme
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/themes/CleanIce/gtk-2.0
+ ${MKDIR} ${PREFIX}/share/themes/CleanIce/metacity-1
+ ${MKDIR} ${PREFIX}/share/themes/CleanIce-Dark/gtk-2.0
+ ${INSTALL_DATA} ${THEMEDIR}/cleanice/index.theme \
+ ${PREFIX}/share/themes/CleanIce
+ ${INSTALL_DATA} ${THEMEDIR}/cleanice/gtkrc \
+ ${PREFIX}/share/themes/CleanIce/gtk-2.0
+ ${INSTALL_DATA} ${THEMEDIR}/cleanice/metacity-theme-1.xml \
+ ${PREFIX}/share/themes/CleanIce/metacity-1
+ ${INSTALL_DATA} ${THEMEDIR}/cleanice-dark/gtkrc \
+ ${PREFIX}/share/themes/CleanIce-Dark/gtk-2.0
+
.include <bsd.port.mk>