aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4/Makefile.kde
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kde4/Makefile.kde')
-rw-r--r--x11/kde4/Makefile.kde32
1 files changed, 0 insertions, 32 deletions
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
index b41db773e375..0de43e3b9cb5 100644
--- a/x11/kde4/Makefile.kde
+++ b/x11/kde4/Makefile.kde
@@ -34,32 +34,6 @@ post-extract:
.endif # !target(post-extract)
.endif # defined(KDE_I18N)
-# Unfortunately, this feature doesn't work right now due to binary files.
-_NO_KDE_PATCHUP=yes
-
-# Start options here.
-.if !defined(_NO_KDE_PATCHUP)
-.if !defined(KDE_PATCHFROM_VER)
-PATCHFROM_VER= ${KDE_ORIGVER}
-.else
-PATCHFROM_VER= ${KDE_PATCHFROM_VER}
-.endif
-.if !defined(KDE_PATCHTO_VER)
-PATCHTO_VER= ${KDE_VERSION}
-.else
-PATCHTO_VER= ${KDE_PATCHTO_VER}
-.endif
-.if !defined(KDE_DISTNAME)
-DISTNAME= ${PORTNAME}-${PATCHFROM_VER}
-.else
-DISTNAME= ${KDE_DISTNAME}
-.endif
-PATCH_SITES= ${MASTER_SITE_LOCAL}
-PATCH_SITE_SUBDIR= will/kde-diffs/${KDE_VERSION}
-PATCHFILES= ${PORTNAME}-${PATCHFROM_VER}-${PATCHTO_VER}.diff.bz2
-PATCH_DIST_STRIP=-p1
-.endif
-
.if !defined(_NO_KDE_FINAL) && defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
@@ -73,12 +47,6 @@ STRIP=''
.endif # defined(PARALLEL_PACKAGE_BUILD) || !defined(WANT_KDE_DEBUG)
.endif # !defined(_NO_KDE_NDEBUG)
-.if !defined(_NO_KDE_NON_I386_OPTS)
-.if ${MACHINE_ARCH} == "alpha"
-CFLAGS= -O0 ${KDE_CFLAGS}
-.endif # ${MACHINE_ARCH} == "alpha"
-.endif # !defined(_NO_KDE_NON_I386_OPTS)
-
.if !defined(_NO_KDE_XINERAMA)
.if !defined(WITHOUT_XINERAMA)
CONFIGURE_ARGS+= --with-xinerama