aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2009-06-06 05:26:49 +0800
committerXan Lopez <xan@gnome.org>2009-06-06 05:29:25 +0800
commit9ac17ac272eb0e08c54a44a7269add7de57a44ea (patch)
tree2d9428dd90a2571198e5633cf4aa10f6bf2fb2a9 /configure.ac
parent8cc5c0f0ceca462741ece79b0ed6e43da878656f (diff)
downloadgsoc2013-epiphany-9ac17ac272eb0e08c54a44a7269add7de57a44ea.tar.gz
gsoc2013-epiphany-9ac17ac272eb0e08c54a44a7269add7de57a44ea.tar.zst
gsoc2013-epiphany-9ac17ac272eb0e08c54a44a7269add7de57a44ea.zip
Remove Python support.
The supported language for extensions other than C/C++ is now JavaScript through Seed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac102
1 files changed, 0 insertions, 102 deletions
diff --git a/configure.ac b/configure.ac
index e081544e2..e717744aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,107 +263,6 @@ fi
AM_CONDITIONAL([ENABLE_SEED],[test "$enable_seed" = "yes"])
-# ******
-# Python
-# ******
-
-AC_MSG_CHECKING([whether Python support is requested])
-AC_ARG_ENABLE([python],
- AS_HELP_STRING([--enable-python],[Enable python support]),
- [enable_python=$enableval have_python=$enableval],
- [enable_python=autodetect have_python=yes])
-AC_MSG_RESULT([$enable_python])
-
-if test "$enable_seed" = "yes" -a "$enable_python" != "no"; then
- AC_MSG_ERROR([cannot enable seed and python support at the same time])
-fi
-
-if test "$have_python" != "no"; then
- AM_PATH_PYTHON([2.3],[],[no])
-
- if test "x$PYTHON" = "x:"; then
- have_python=no
- fi
-fi
-
-if test "$have_python" != "no"; then
- AM_CHECK_PYTHON_HEADERS([],[have_python=no])
-fi
-
-if test "$have_python" != "no"; then
- PY_PREFIX=`$PYTHON -c 'import sys ; print sys.prefix'`
- PY_EXEC_PREFIX=`$PYTHON -c 'import sys ; print sys.exec_prefix'`
- PYTHON_LIBS="-lpython$PYTHON_VERSION"
- PYTHON_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PYTHON_VERSION/config"
- PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION"
- PYTHON_MAKEFILE="$PY_EXEC_PREFIX/lib/python$PYTHON_VERSION/config/Makefile"
- PYTHON_LOCALMODLIBS=`sed -n -e 's/^LOCALMODLIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
- PYTHON_BASEMODLIBS=`sed -n -e 's/^BASEMODLIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
- PYTHON_OTHER_LIBS=`sed -n -e 's/^LIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
- PYTHON_EXTRA_LIBS="$PYTHON_LOCALMODLIBS $PYTHON_BASEMODLIBS $PYTHON_OTHER_LIBS"
- AC_SUBST([PYTHON_LIBS])
- AC_SUBST([PYTHON_LIB_LOC])
- AC_SUBST([PYTHON_CFLAGS])
- AC_SUBST([PYTHON_EXTRA_LIBS])
-fi
-
-if test "$have_python" != "no"; then
- PYGTK_REQUIRED=2.7.1
- GNOME_PYTHON_REQUIRED=2.6.0
-
- PKG_CHECK_MODULES([PYGTK], [pygtk-2.0 >= $PYGTK_REQUIRED gnome-python-2.0 >= $GNOME_PYTHON_REQUIRED],
- [],[have_python=no])
-
- AC_SUBST([PYGTK_CFLAGS])
- AC_SUBST([PYGTK_LIBS])
-fi
-
-if test "$have_python" != "no"; then
- AC_MSG_CHECKING([for pygtk defs])
- PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
- AC_MSG_RESULT([$PYGTK_DEFSDIR])
-
- AC_MSG_CHECKING([for pygtk codegen])
- PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
- AC_MSG_RESULT([$PYGTK_CODEGEN])
-
- AC_MSG_CHECKING([for pygtk h2def])
- PYGTK_H2DEF="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/h2def.py"
- AC_MSG_RESULT([$PYGTK_H2DEF])
-
- AC_SUBST([PYGTK_DEFSDIR])
- AC_SUBST([PYGTK_CODEGEN])
- AC_SUBST([PYGTK_H2DEF])
-
- # Check for -fno-strict-aliasing
- FLAGS="-fno-strict-aliasing"
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $FLAGS"
- AC_MSG_CHECKING([whether [$]CC understands $FLAGS])
- AC_TRY_COMPILE([], [], [compiler_has_option=yes], [compiler_has_option=no])
- CFLAGS="$save_CFLAGS"
- AC_MSG_RESULT($compiler_has_option)
- if test $compiler_has_option = yes; then
- NO_STRICT_ALIASING_CFLAGS="$FLAGS"
- fi
- AC_SUBST([NO_STRICT_ALIASING_CFLAGS])
-fi
-
-if test "$have_python" != "yes"; then
- if test "$enable_python" = "yes"; then
- AC_MSG_ERROR([Python not found])
- elif test "$enable_python" = "autodetect"; then
- enable_python=no
- AC_MSG_WARN([Python not found, disabling python support])
- fi
-elif test "$enable_python" != "no"; then
- enable_python=yes
- AC_DEFINE([ENABLE_PYTHON],[1],[Define to compile with python support])
- EPIPHANY_FEATURES="$EPIPHANY_FEATURES python"
-fi
-
-AM_CONDITIONAL([ENABLE_PYTHON],[test "$enable_python" = "yes"])
-
AC_SUBST([EPIPHANY_FEATURES])
# *******************
@@ -572,6 +471,5 @@ Epiphany was configured with the following options:
NetworkManager support : $enable_network_manager
GObject introspection : $enable_introspection
Seed support : $enable_seed
- Python support : $enable_python
Build tests : $enable_tests
"
n>/+1 * Cram into 80 columns by 24 rows.trevor2004-04-111-35/+9 * - give a more specific URL to fetch the distfile frompetef2004-01-112-7/+3 * Mark as broken on recent versions of -current due to use of varags.hlinimon2003-12-282-3/+8 * fix the compile when bison is installedoliver2003-12-141-1/+5 * ECHO -> ECHO_MSGedwin2003-09-271-1/+1 * Teach stdarg.hache2003-09-245-1/+187 * RESTRICTED implies NO_PACKAGEkris2003-07-311-1/+0 * De-pkg-comment.knu2003-02-212-1/+1 * /usr/bin/chgrp -> ${CHGRP}arved2002-11-191-2/+2 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-112-2/+1 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-072-1/+2 * ${PERL} -> ${REINPLACE_CMD}dwcjr2002-09-021-0/+1 * Remove -l in su call - not neededache2002-08-242-2/+2 * Fix startup-scripts for -current /bin/sh issues.anders2002-08-141-1/+4 * Suggest user deleting command instead of using it automaticallyache2001-12-082-6/+2 * Style police: WWW tags should either end in a file/script or TRAILING /; Fix ...lioux2001-11-211-1/+1