aboutsummaryrefslogtreecommitdiffstats
path: root/art/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2007-02-13 02:11:51 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2007-02-13 02:11:51 +0800
commit876e40f9057b0ef9948e58b7c2253c53d0388f10 (patch)
tree430dcd6afc4f069ea3ed60881baee763a5191579 /art/Makefile.am
parent650e7524ed23df43dbce67b7f9e54f3d2df936b5 (diff)
downloadgsoc2013-evolution-876e40f9057b0ef9948e58b7c2253c53d0388f10.tar.gz
gsoc2013-evolution-876e40f9057b0ef9948e58b7c2253c53d0388f10.tar.zst
gsoc2013-evolution-876e40f9057b0ef9948e58b7c2253c53d0388f10.zip
** Fixes bug #350253
2007-02-12 Matthew Barnes <mbarnes@redhat.com> ** Fixes bug #350253 * Add new evolution icons: art/16x16/evolution.png art/22x22/evolution.png art/24x24/evolution.png art/32x32/evolution.png art/scalable/evolution.svg * Remove obsolete icons: art/about-box.png art/bcg.png art/evolution.png art/monkey-16.png * art/Makefile.am: Ship our own named icons. * mail/em-format-html-print.h: Rename show_rupert field to show_icon. * mail/em-format-html-print.c (efh_format_headers): Lookup the evolution icon by name. svn path=/trunk/; revision=33211
Diffstat (limited to 'art/Makefile.am')
-rw-r--r--art/Makefile.am43
1 files changed, 30 insertions, 13 deletions
diff --git a/art/Makefile.am b/art/Makefile.am
index 08d8048520..575a559c79 100644
--- a/art/Makefile.am
+++ b/art/Makefile.am
@@ -1,8 +1,22 @@
+icon16dir = $(datadir)/icons/hicolor/16x16/apps
+icon16_DATA = 16x16/evolution.png
+
+icon22dir = $(datadir)/icons/hicolor/22x22/apps
+icon22_DATA = 22x22/evolution.png
+
+icon24dir = $(datadir)/icons/hicolor/24x24/apps
+icon24_DATA = 24x24/evolution.png
+
+icon32dir = $(datadir)/icons/hicolor/32x32/apps
+icon32_DATA = 32x32/evolution.png
+
+svgicondir = $(datadir)/icons/hicolor/scalable/apps
+svgicon_DATA = scalable/evolution.svg
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
images_DATA = \
- about-box.png \
- bcg.png \
evolution-contacts-mini.png \
- monkey-16.png \
offline.png \
online.png \
world_map-960.png \
@@ -10,15 +24,14 @@ images_DATA = \
plus.png \
minus.png
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps
- $(INSTALL_DATA) $(srcdir)/evolution.png $(DESTDIR)$(datadir)/pixmaps/evolution-$(BASE_VERSION).png
-if DEFAULT_BINARY
- cd $(DESTDIR)$(datadir)/pixmaps && rm -f evolution.png && $(LN_S) evolution-$(BASE_VERSION).png evolution.png
-endif
-
-uninstall-local:
- rm -f $(DESTDIR)$(datadir)/pixmaps/evolution-$(BASE_VERSION).png
+install-data-hook:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
EXTRA_DIST = \
ChangeLog \
@@ -27,6 +40,10 @@ EXTRA_DIST = \
broken-image-16.xpm \
broken-image-24.xpm \
empty.xpm \
- evolution.png \
jump.xpm \
+ $(icon16_DATA) \
+ $(icon22_DATA) \
+ $(icon24_DATA) \
+ $(icon32_DATA) \
+ $(svgicon_DATA) \
$(images_DATA)