aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@novell.com>2004-08-13 05:08:49 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2004-08-13 05:08:49 +0800
commit05d3da3bf695dcdc5614cc1434926812a21902b9 (patch)
tree3c348e656dcbb905af5f3a63ccd99b85060c00a8 /configure.in
parentf9394de34e96c96d7096e32694165e1cfa2526f9 (diff)
downloadgsoc2013-evolution-05d3da3bf695dcdc5614cc1434926812a21902b9.tar.gz
gsoc2013-evolution-05d3da3bf695dcdc5614cc1434926812a21902b9.tar.zst
gsoc2013-evolution-05d3da3bf695dcdc5614cc1434926812a21902b9.zip
Check for gtk+-2.4 in order to enable the use of GtkFileChooser.
2004-08-12 Jeffrey Stedfast <fejj@novell.com> * configure.in: Check for gtk+-2.4 in order to enable the use of GtkFileChooser. svn path=/trunk/; revision=26899
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 35bfab7f48..e6fec442da 100644
--- a/configure.in
+++ b/configure.in
@@ -1007,6 +1007,14 @@ AC_DEFUN(EVO_SET_COMPILE_FLAGS, [
$1_LIBS="$EVOLUTION_LIBS $extra_libs"
])
+dnl enable USE_GTKFILECHOOSER if gtk version is > 2.4.0
+AC_ARG_ENABLE(file-chooser, [ --enable-file-chooser Enable the usage of the GtkFileChooser in place of the GtkFileSelection dialog], enable_file_chooser="$enableval", enable_file_chooser="yes")
+if test "x$enable_file_chooser" = "xyes"; then
+ if pkg-config --atleast-version=2.4.0 gtk+-2.0; then
+ AC_DEFINE(USE_GTKFILECHOOSER,1,[Use new GtkFileChooser])
+ fi
+fi
+
dnl --- Required version numbers
GAL_REQUIRED=2.1.13