aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/calendar-weather/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-06-27 08:55:24 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-06-27 08:55:24 +0800
commit1e47292c45b08fad3c4d12364d9713c069579a95 (patch)
treea15819a64f5e65e2530525c48e9f14e70a914756 /plugins/calendar-weather/Makefile.am
parent624fae240b1cf5a216129d0dc2a5913f0216ae59 (diff)
downloadgsoc2013-evolution-1e47292c45b08fad3c4d12364d9713c069579a95.tar.gz
gsoc2013-evolution-1e47292c45b08fad3c4d12364d9713c069579a95.tar.zst
gsoc2013-evolution-1e47292c45b08fad3c4d12364d9713c069579a95.zip
Use NO_UNDEFINED. Link with more libraries.
2005-06-27 Tor Lillqvist <tml@novell.com> * */Makefile.am: Use NO_UNDEFINED. Link with more libraries. svn path=/trunk/; revision=29593
Diffstat (limited to 'plugins/calendar-weather/Makefile.am')
-rw-r--r--plugins/calendar-weather/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/plugins/calendar-weather/Makefile.am b/plugins/calendar-weather/Makefile.am
index 06c45d58d4..598521073b 100644
--- a/plugins/calendar-weather/Makefile.am
+++ b/plugins/calendar-weather/Makefile.am
@@ -3,7 +3,6 @@ weatherdatadir = $(datadir)/evolution/$(BASE_VERSION)/weather
INCLUDES = \
-I$(top_srcdir)/shell \
- $(EVOLUTION_CFLAGS) \
$(EVOLUTION_CALENDAR_CFLAGS) \
$(SOURCE_SEL_CFLAGS) \
-DWEATHER_DATADIR=\""$(weatherdatadir)"\" \
@@ -24,7 +23,10 @@ plugin_DATA = org-gnome-calendar-weather.eplug
plugin_LTLIBRARIES = liborg-gnome-calendar-weather.la
liborg_gnome_calendar_weather_la_SOURCES = calendar-weather.c
-liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version
+liborg_gnome_calendar_weather_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+liborg_gnome_calendar_weather_la_LIBADD = \
+ $(top_builddir)/calendar/gui/libevolution-calendar.la \
+ $(EVOLUTION_CALENDAR_LIBS)
EXTRA_DIST = \
org-gnome-calendar-weather.eplug.xml \