aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/itip-formatter/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@novell.com>2005-01-04 01:24:12 +0800
committerJP Rosevear <jpr@src.gnome.org>2005-01-04 01:24:12 +0800
commit1d499afd8063d5f9ae951aec14b6bba9054bd1db (patch)
tree2362b3b6733d83993432985df0db069db116c401 /plugins/itip-formatter/Makefile.am
parent4cb6cea812a9c2ac31402071005193dadecb646e (diff)
downloadgsoc2013-evolution-1d499afd8063d5f9ae951aec14b6bba9054bd1db.tar.gz
gsoc2013-evolution-1d499afd8063d5f9ae951aec14b6bba9054bd1db.tar.zst
gsoc2013-evolution-1d499afd8063d5f9ae951aec14b6bba9054bd1db.zip
add response enums
2005-01-03 JP Rosevear <jpr@novell.com> * itip-view.h: add response enums * itip-view.c (set_buttons): fiddle with button names and response enums * itip-formatter.c (find_server): don't include our uid in the conflicts search (update_attendee_status): update the status of the attendee and save it out (adjust_item): get relevant properties for items that might contain them if sent from an attendee (get_real_item): get the actual, current item (send_item): send the item (view_response_cb): handle REPLY and REFRESH requests (format_itip_object): adjust the item if necessary and set the attendee for reply/refresh; prevent crash if no description (pitip_free): skeleton free function (format_itip): load delete message setting (delete_toggled_cb): set delete message setting based on toggle (itip_formatter_page_factory): make the delete message check box work * Makefile.am: install e-error messages svn path=/trunk/; revision=28216
Diffstat (limited to 'plugins/itip-formatter/Makefile.am')
-rw-r--r--plugins/itip-formatter/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/plugins/itip-formatter/Makefile.am b/plugins/itip-formatter/Makefile.am
index 418d43830c..6805a7c9f6 100644
--- a/plugins/itip-formatter/Makefile.am
+++ b/plugins/itip-formatter/Makefile.am
@@ -11,4 +11,12 @@ plugin_LTLIBRARIES = liborg-gnome-itip-formatter.la
liborg_gnome_itip_formatter_la_SOURCES = itip-formatter.c itip-view.c itip-view.h
liborg_gnome_itip_formatter_la_LDFLAGS = -module -avoid-version
+error_DATA = org-gnome-itip-formatter-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
+errordir = $(privdatadir)/errors
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
+
+BUILT_SOURCES = $(error_i18n)
+
EXTRA_DIST = org-gnome-itip-formatter.eplug.in \ No newline at end of file