aboutsummaryrefslogtreecommitdiffstats
path: root/win32/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-06-16 03:05:11 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-06-16 03:05:11 +0800
commit039812d8add16b44e9fdb2918e692e1a5e2458df (patch)
treedf08c1d72b974f46459f11d624142bccb685a760 /win32/Makefile.am
parent66ef21857ab86f54789eca8a52687b1e915ac624 (diff)
downloadgsoc2013-evolution-039812d8add16b44e9fdb2918e692e1a5e2458df.tar.gz
gsoc2013-evolution-039812d8add16b44e9fdb2918e692e1a5e2458df.tar.zst
gsoc2013-evolution-039812d8add16b44e9fdb2918e692e1a5e2458df.zip
win32/README win32/Makefile.am win32/dummy.la win32/libemiscwidgets.def
2005-06-15 Tor Lillqvist <tml@novell.com> * win32/README * win32/Makefile.am * win32/dummy.la * win32/libemiscwidgets.def * win32/libevolution-addressbook.def * win32/libevolution-calendar.def * win32/libevolution-mail.def * win32/libfilter.def: New files. Build bootstrap import libraries for some of Evolution's DLLs to work around circular dependencies between some of the shared libraries. Circular dependecies are problematic on Win32 where one can't have undefined symbols in executables (or shared libraries). svn path=/trunk/; revision=29508
Diffstat (limited to 'win32/Makefile.am')
-rw-r--r--win32/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/win32/Makefile.am b/win32/Makefile.am
new file mode 100644
index 0000000000..e1f874f372
--- /dev/null
+++ b/win32/Makefile.am
@@ -0,0 +1,51 @@
+EXTRA_DIST =
+ README \
+ dummy.la \
+ libemiscwidgets.def \
+ libevolution-addressbook.def \
+ libevolution-calendar.def \
+ libevolution-mail.def \
+ libfilter.def
+
+if OS_WIN32
+BOOTSTRAP_LIBS = \
+ libemiscwidgets.la \
+ libevolution-addressbook.la \
+ libevolution-calendar.la \
+ libevolution-mail.la \
+ libfilter.la
+endif
+
+noinst_DATA = $(BOOTSTRAP_LIBS)
+
+# Yes, it's a bit silly to repeat the same command sequence here
+# multiple times, but on the other hand there are subtle differences:
+# Part of the DLLs have -0 in the name, part don't. (Those linked with
+# libtool's -module -avoid-version options don't get the -0 suffix.)
+
+libemiscwidgets.la: dummy.la libemiscwidgets.def
+ sed -e s!%DLL%!libemiscwidgets-0! -e s!%LIB%!libemiscwidgets! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ dlltool --output-lib=.libs/libemiscwidgets.dll.a --dllname=libemiscwidgets-0.dll --input-def=libemiscwidgets.def
+
+libevolution-addressbook.la: dummy.la libevolution-addressbook.def
+ sed -e s!%DLL%!libevolution-addressbook! -e s!%LIB%!libevolution-addressbook! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ dlltool --output-lib=.libs/libevolution-addressbook.dll.a --dllname=libevolution-addressbook.dll --input-def=libevolution-addressbook.def
+
+libevolution-calendar.la: dummy.la libevolution-calendar.def
+ sed -e s!%DLL%!libevolution-calendar! -e s!%LIB%!libevolution-calendar! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ dlltool --output-lib=.libs/libevolution-calendar.dll.a --dllname=libevolution-calendar.dll --input-def=libevolution-calendar.def
+
+libevolution-mail.la: dummy.la libevolution-mail.def
+ sed -e s!%DLL%!libevolution-mail! -e s!%LIB%!libevolution-mail! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ dlltool --output-lib=.libs/libevolution-mail.dll.a --dllname=libevolution-mail.dll --input-def=libevolution-mail.def
+
+libfilter.la: dummy.la libfilter.def
+ sed -e s!%DLL%!libfilter-0! -e s!%LIB%!libfilter! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ dlltool --output-lib=.libs/libfilter.dll.a --dllname=libfilter-0.dll --input-def=libfilter.def
+
+CLEANFILES = $(BOOTSTRAP_LIBS)