aboutsummaryrefslogtreecommitdiffstats
path: root/win32/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-06-18 09:01:20 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-06-18 09:01:20 +0800
commitb7d8d607827cefabf03865cf054746ed6517b4bd (patch)
treeed5af1ec415e9c82d91bbccde0c073a568cf34bf /win32/Makefile.am
parent927d1658f64c2507e331685d931d08f145014a03 (diff)
downloadgsoc2013-evolution-b7d8d607827cefabf03865cf054746ed6517b4bd.tar.gz
gsoc2013-evolution-b7d8d607827cefabf03865cf054746ed6517b4bd.tar.zst
gsoc2013-evolution-b7d8d607827cefabf03865cf054746ed6517b4bd.zip
Add libetable and libetext.
2005-06-18 Tor Lillqvist <tml@novell.com> * win32/Makefile.am (EXTRA_DIST): Add libetable and libetext. * win32/libetable.def * win32/libetext.def: New files. * win32/libemiscwidgets.def: Add new entries. svn path=/trunk/; revision=29529
Diffstat (limited to 'win32/Makefile.am')
-rw-r--r--win32/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/win32/Makefile.am b/win32/Makefile.am
index 6d35a8bac1..d2c15e42f2 100644
--- a/win32/Makefile.am
+++ b/win32/Makefile.am
@@ -1,6 +1,8 @@
EXTRA_DIST = \
dummy.la \
libemiscwidgets.def \
+ libetable.def \
+ libetext.def \
libevolution-addressbook.def \
libevolution-calendar.def \
libevolution-mail.def \
@@ -9,6 +11,8 @@ EXTRA_DIST = \
if OS_WIN32
BOOTSTRAP_LIBS = \
libemiscwidgets.la \
+ libetable.la \
+ libetext.la \
libevolution-addressbook.la \
libevolution-calendar.la \
libevolution-mail.la \
@@ -27,6 +31,16 @@ libemiscwidgets.la: dummy.la libemiscwidgets.def
mkdir -p .libs
dlltool --output-lib=.libs/libemiscwidgets.dll.a --dllname=libemiscwidgets-0.dll --input-def=libemiscwidgets.def
+libetable.la: dummy.la libetable.def
+ sed -e s!%DLL%!libetable! -e s!%LIB%!libetable! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ dlltool --output-lib=.libs/libetable.dll.a --dllname=libetable.dll --input-def=libetable.def
+
+libetext.la: dummy.la libetext.def
+ sed -e s!%DLL%!libetext! -e s!%LIB%!libetext! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ dlltool --output-lib=.libs/libetext.dll.a --dllname=libetext.dll --input-def=libetext.def
+
libevolution-addressbook.la: dummy.la libevolution-addressbook.def
sed -e s!%DLL%!libevolution-addressbook! -e s!%LIB%!libevolution-addressbook! -e s!%PFX%!$(prefix)! <dummy.la >$@
mkdir -p .libs