aboutsummaryrefslogtreecommitdiffstats
path: root/help/devel/importer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'help/devel/importer/Makefile.am')
-rw-r--r--help/devel/importer/Makefile.am195
1 files changed, 0 insertions, 195 deletions
diff --git a/help/devel/importer/Makefile.am b/help/devel/importer/Makefile.am
deleted file mode 100644
index 8b5343677a..0000000000
--- a/help/devel/importer/Makefile.am
+++ /dev/null
@@ -1,195 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-# The name of the module, e.g. 'glib'.
-DOC_MODULE=evolution-shell-importer
-
-# The top-level SGML file. Change it if you want.
-DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
-
-# The directory containing the source code. Relative to $(srcdir).
-# gtk-doc will search all .c & .h files beneath here for inline comments
-# documenting functions and macros.
-DOC_SOURCE_DIR=$(EVOLUTION_DIR)/shell/importer
-
-# Extra options to supply to gtkdoc-scan.
-SCAN_OPTIONS=
-
-# Extra options to supply to gtkdoc-mkdb.
-MKDB_OPTIONS=
-
-# Extra options to supply to gtkdoc-fixref.
-FIXXREF_OPTIONS=
-
-# Used for dependencies.
-HFILE_GLOB= \
- $(top_srcdir)/shell/importer/evolution-importer.h \
- $(top_srcdir)/shell/importer/evolution-importer-client.h
-
-CFILE_GLOB= \
- $(top_srcdir)/shell/importer/evolution-importer.c \
- $(top_srcdir)/shell/importer/evolution-importer-client.c
-
-# Header files to ignore when scanning.
-IGNORE_HFILES= \
- GNOME_Evolution_Importer.h \
- importer.h
-
-# Images to copy into HTML directory.
-HTML_IMAGES =
-
-# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
-content_files =
-
-# Other files to distribute.
-extra_files =
-
-# CFLAGS and LDFLAGS for compiling scan program. Only needed if your app/lib
-# contains GtkObjects/GObjects and you want to document signals and properties.
-GTKDOC_CFLAGS = \
- -I$(top_srcdir)/shell/importer \
- -I$(top_srcdir)/shell \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- $(BONOBO_VFS_GNOME_CFLAGS)
-
-GTKDOC_LIBS = \
- $(BONOBO_VFS_GNOME_LIBS) \
- $(top_builddir)/shell/importer/.libs/libevolution-importer.so
-
-GTKDOC_CC=$(LIBTOOL) --mode=compile $(CC)
-GTKDOC_LD=$(LIBTOOL) --mode=link $(CC)
-
-# If you need to override some of the declarations, place them in this file
-# and uncomment this line.
-#DOC_OVERRIDES = $(DOC_MODULE)-overrides.txt
-DOC_OVERRIDES =
-
-###########################################################################
-# Everything below here is generic and you shouldn't need to change it.
-###########################################################################
-
-TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
-
-EXTRA_DIST = \
- $(content_files) \
- $(extra_files) \
- $(HTML_IMAGES) \
- $(DOC_MAIN_SGML_FILE) \
- $(DOC_MODULE).types \
- $(DOC_MODULE)-sections.txt \
- $(DOC_OVERRIDES)
-
-DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
- $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp
-
-SCANOBJ_FILES = \
- $(DOC_MODULE).args \
- $(DOC_MODULE).hierarchy \
- $(DOC_MODULE).signals
-
-if ENABLE_GTK_DOC
-#all-local: html-build.stamp
-all-local: sgml-build.stamp
-
-#### scan ####
-
-scan-build.stamp: $(HFILE_GLOB)
- @echo '*** Scanning header files ***'
- if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null ; then \
- CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scanobj --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
- else \
- cd $(srcdir) ; \
- for i in $(SCANOBJ_FILES) ; do \
- test -f $$i || touch $$i ; \
- done \
- fi
- cd $(srcdir) && \
- gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
- touch scan-build.stamp
-
-$(DOC_MODULE)-decl.txt $(SCANOBJ_FILES): scan-build.stamp
- @true
-
-#### templates ####
-
-tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_OVERRIDES)
- @echo '*** Rebuilding template files ***'
- cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE)
- touch tmpl-build.stamp
-
-tmpl.stamp: tmpl-build.stamp
- @true
-
-#### sgml ####
-
-sgml-build.stamp: tmpl.stamp $(CFILE_GLOB) $(srcdir)/tmpl/*.sgml
- @echo '*** Building SGML ***'
- cd $(srcdir) && \
- gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --main-sgml-file=$(DOC_MAIN_SGML_FILE) $(MKDB_OPTIONS)
- touch sgml-build.stamp
-
-sgml.stamp: sgml-build.stamp
- @true
-
-#### html ####
-
-html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
- @echo '*** Building HTML ***'
- test -d $(srcdir)/html || mkdir $(srcdir)/html
- cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
- test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
- @echo '-- Fixing Crossreferences'
- cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
- touch html-build.stamp
-endif
-
-##############
-
-clean-local:
- rm -f *~ *.bak $(SCANOBJ_FILES) *-unused.txt $(DOC_STAMPS)
-
-maintainer-clean-local: clean
- cd $(srcdir) && rm -rf sgml html $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
-
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR)
- (installfiles=`echo $(srcdir)/html/*.html`; \
- if test "$$installfiles" = '$(srcdir)/html/*.html'; \
- then echo '-- Nothing to install' ; \
- else \
- for i in $$installfiles; do \
- echo '-- Installing '$$i ; \
- $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
- done; \
- echo '-- Installing $(srcdir)/html/index.sgml' ; \
- $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR); \
- fi)
-
-#
-# Require gtk-doc when making dist
-#
-if ENABLE_GTK_DOC
-dist-check-gtkdoc:
-else
-dist-check-gtkdoc:
- @echo "*** gtk-doc must be installed and enabled in order to make dist"
- @false
-endif
-
-dist-hook: dist-check-gtkdoc dist-hook-local
- mkdir $(distdir)/tmpl
- mkdir $(distdir)/sgml
- mkdir $(distdir)/html
- -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
- -cp $(srcdir)/sgml/*.sgml $(distdir)/sgml
- -cp $(srcdir)/html/index.sgml $(distdir)/html
- -cp $(srcdir)/html/*.html $(srcdir)/html/*.css $(distdir)/html
-
- images=$(HTML_IMAGES) ; \
- for i in $$images ; do \
- cp $(srcdir)/$$i $(distdir)/html ; \
- done
-
-.PHONY : dist-hook-local
-
-
class='deletions'>-0/+204 * New port: biology/fasta, the FASTA2 suite of DNA and protein sequencejeh2001-02-128-0/+151 * add gaussian98, an ab-initio molecular orbital calculation program.sf2001-02-1112-0/+822 * Update to 0.84a. Generate the plist.trevor2001-02-093-8/+10 * - Update EMBOSS (biology/emboss) from 1.9.0 to 1.9.1kevlo2001-01-2910-77/+118 * update from 3.7 to 3.8ijliao2001-01-2518-167/+706 * Upgrade to version 1.9.0kevlo2001-01-246-13/+47 * Massive style enforcement - use ^I instead of spaces for variables identation.sobomax2001-01-171-2/+2 * Clean up inefficient perl invocations; use multiple REs in the same call.will2001-01-081-2/+2 * Update to 1.2.6kevlo2000-12-234-7/+25 * Remove trailing period and package name from the pkg-comment.demon2000-12-191-1/+1 * Update to version 5.79.steve2000-12-113-26/+42 * Update distfiles' checksums after the distfiles have been rerolled yetroam2000-12-042-4/+5 * Distfile tarballs were rerolled without notice due to a minor bug.roam2000-12-011-4/+4 * - Update port biology/emboss from 1.7.0 to 1.8.0jeh2000-11-284-17/+124 * Make nolonger support :U. Fix to compensate for that.jeh2000-11-191-3/+6 * They made changes to the "blast" program.jeh2000-11-152-2/+3 * - This is a fairly extensive rework of this port.jeh2000-11-133-0/+56 * - This is a fairly extensive rework of this port.jeh2000-11-134-5/+150 * Change motif to a normal dependency. REQUIRES_MOTIF is now calledasami2000-11-081-1/+1 * Yes. They did re-roll this version, it is legit.jeh2000-11-032-2/+2 * Updated to new version. That is the pits, the day after it becomesjeh2000-11-024-4/+3 * Make portlint happy, remove a spacejeh2000-11-011-1/+1 * Update to version 1.7.0jeh2000-11-013-2/+11 * File missing in pkg-plistjeh2000-10-301-0/+1 * New Port: biology/ncbi-toolkitjeh2000-10-2911-0/+376 * Update biology/sim4 to 2000.10.19jeh2000-10-263-5/+7 * gmake is neededjeh2000-10-241-0/+1 * Update to version 0.6.2jeh2000-10-133-174/+132 * A file was added to distfile and then repackaged with the same name.jeh2000-10-133-2/+5 * Initial import of fastDNAml Version 1.2.2jeh2000-10-126-0/+93 * Missing " in post-patch targetjeh2000-10-111-1/+1 * PR 21608 was not processed as intented.jeh2000-10-112-21/+22 * Initial import of biology/biojavajeh2000-10-106-0/+661 * - Update to 1.6.0kevlo2000-10-103-363/+372 * - Update biology/p5-AcePerl from 1.62 to 1.67kevlo2000-10-106-61/+88 * Initiail version of nab (4.2)jeh2000-10-1017-0/+666 * This is nab (nucleic acid builder), a language for macromoleculesjeh2000-10-101-0/+1 * - Fix MASTER_SITES/DISTNAMEjeh2000-10-103-20/+19 * The last commit changes the ports and therefore need a PORTREVISION bumpjeh2000-10-102-0/+2 * Support PREFIX properlyjeh2000-10-102-1/+5 * - Fix MASTER_SITESjeh2000-10-104-18/+36 * Add do-install target to port's Makefile. Remove patch sectiontrevor2000-10-092-10/+5 * Change PKGDIR from pkg/ to . Also fix places where ${PKGDIR} isasami2000-10-081-1/+1 * Rename ${FILESDIR}/patch-* to ${PATCHDIR}/extra-patch-*.asami2000-10-081-2/+2 * Implement USE_GTK, part 1.reg2000-10-053-38/+26 * - Support CC/CFLAGS/PREFIX properlyjeh2000-10-036-8/+127 * Correct and sort PLISTs.reg2000-10-032-6/+6 * Change MAINTAINER for my ports.trevor2000-10-021-1/+1 * Add USE_XLIBkris2000-09-221-0/+1 * respect CXX and CXXFLAGS (Kato Tsuguru)ade2000-09-194-20/+39 * Update to 0.90.d03nbm2000-09-113-132/+152 * Fix checksumkevlo2000-09-091-18/+1 * Don't break package building on Satoshi's cluster. Explicitly dependtg2000-09-081-1/+1 * Upgrade to 1.5.0nbm2000-09-084-66/+113 * Update to emboss 1.4.0.nbm2000-09-074-52/+83 * Update to version 2000.08.24kevlo2000-09-044-7/+23 * USE_LIBTOOL implies GNU_CONFIGURE, so remove redundant GNU_CONFIGURE lines.sobomax2000-08-211-1/+0 * Update to emboss 1.1.0, fixing some style bugs too.nbm2000-08-135-6/+321 * Upgrade to 0.90.d02.will2000-08-062-3/+3 * Fix MASTER_SITESjedgar2000-08-021-1/+1 * Add emboss, the European Molecular Biology Open Software Suitenbm2000-08-016-0/+700 * Add py-biopython, is a collection of Python packages and modules creatednbm2000-07-316-0/+166 * Add BioPerl, a collection of Perl5 mods for bioinformatics/genomicsnbm2000-07-287-0/+259 * Add p5-AcePerl, a perl interface to the ACEDB genome database systemnbm2000-07-289-0/+177 * Add sim4, an implementation of the sim4 algorithm for aligning expressednbm2000-07-277-0/+48 * Add xdrawchem 0.82 - a program for drawing moleculesalex2000-07-197-0/+65 * Activating the chemeq, clustalw, paml, and phylip ports.steve2000-07-101-0/+4 * Adding phylip version 3.5.steve2000-07-105-0/+161 * Add paml version 3.01.steve2000-07-107-0/+89 * Adding clustalw version 1.81.steve2000-07-106-0/+66 * Adding chemeq version 1.10.steve2000-07-105-0/+62 * - Use GTK_CONFIG/GLIB_CONFIG instead of hardcoded gtk12-config/glib12-configsteve2000-07-082-19/+27 * Unbreak by extracting the correct distfilekris2000-07-031-8/+2 * ...local-distfiles... -> MASTER_SITE_LOCALalex2000-06-201-1/+2 * fc is ftn77 now, adjust accordingly.alex2000-06-123-5/+6 * Update to version 1.0.3alex2000-06-114-24/+23 * Clean up this port so that it installs stuff in a more proper locationwill2000-06-093-138/+138 * Update to the latest version as of 5 June.knu2000-06-084-15/+26 * Fix build for 4.0 and later. Make DESCR shorter.will2000-06-085-165/+181 * Update to 3.6.will2000-06-086-114/+145 * Convert to usable F77 binary, especially on 4.0 and newer.will2000-06-084-82/+73 * Fix MD5 checksum. Since I was unable to find an older version of thewill2000-06-051-1/+1 * Fix this port after the recent PORT{NAME,VERSION} changes. portlint(1)steve2000-05-281-2/+4 * Update to version 2000.04.26.steve2000-05-283-5/+3 * Chase the checksum (lots of code changes)kris2000-04-241-1/+1 * WRKSRC-related fixes.asami2000-04-161-0/+1 * update with the new PORTNAME/PORTVERSION variablesmharo2000-04-0915-53/+51 * Remove andy@icc.surw.chel.su as maintainer from his ports..he doesn'tkris2000-03-291-1/+1 * Add virtual category "linux" to Linux apps and support libs/utils.asami2000-02-281-1/+1 * Chase the checksum (minor source changes)kris2000-02-271-1/+1 * update URLsmharo2000-02-241-2/+2 * update WWWmharo2000-02-241-1/+1 * Forgot to remove this linecpiazza2000-02-071-1/+0 * Don't strip things we don't know how to stripcpiazza2000-01-311-1/+1 * fix some pkg/MESSAGE stuffmharo2000-01-302-2/+2 * Update to ver 1.2.2cpiazza2000-01-152-3/+3 * Bump glib12 's share library version to 3,vanilla1999-10-102-10/+2 * f77(1) on the Alpha doesn't grok '-malign-double' so only use it on thesteve1999-09-271-0/+4 * Enforce random pkg/COMMENT rules, including the one that states Emacshoek1999-09-182-2/+2 * Grammar and WWW: fix.hoek1999-09-181-7/+6 * Update to new version.steve1999-09-183-8/+5 * Compile-errortaoka1999-09-102-3/+9 * Compile errortaoka1999-09-091-1/+1 * Added gperiodic and xmolwttaoka1999-09-071-0/+2 * Displays a periodic table of the elements.taoka1999-09-075-0/+58 * This program calculate formula weight and percent of each elements.taoka1999-09-076-0/+82 * Distfile changed on the MASTER_SITE. I have no idea if thiscpiazza1999-08-312-6/+6 * Remove preceeding pkgname from some of the comments having one.hoek1999-08-301-1/+1 * grammar gnithoek1999-08-301-1/+1 * ln -> ${LN}mharo1999-08-282-2/+2 * echo -> ${ECHO} or ${ECHO_MSG} and in some cases, move echo stuffmharo1999-08-281-8/+8 * Updated to 2.7.1taoka1999-08-253-11/+24 * Change Id->FreeBSD.obrien1999-08-2514-14/+14 * Make port depend on linux_base instead of linux_lib.marcel1999-07-211-3/+3 * Fix typos and/or cleanup WWW:.hoek1999-07-174-18/+13 * BROKEN='MD5 checksum error'obrien1999-07-151-1/+3 * Fix port after distfile change.cpiazza1999-07-112-3/+2 * Remove trailing spaces, and any periods that were hidden by them.hoek1999-06-282-2/+2 * As threatened, enforce the "Capital, no period" rule. Ellipses arehoek1999-06-279-9/+9 * Install into ${PREFIX}, not /usr/local.cpiazza1999-06-263-7/+7 * Clean up warnings for -current (g77)cpiazza1999-06-251-7/+9 * Change ${INSTALL} to use -s and -c.cpiazza1999-06-241-45/+45 * Update tinker from version 3.6 to version 3.7cpiazza1999-06-237-310/+289 * Make the psi88 port install into PREFIX instead of a hardcodedcpiazza1999-06-191-4/+14 * The xforms ports is no longer an i386-only port.steve1999-06-091-4/+1 * Fill in a couple of missing WWW references...scrappy1999-06-052-0/+4 * Fix build for -current boxes with egcs' f77 compiler.steve1999-05-242-11/+29 * Allow this port to be built on -current i386 boxes that have egcs' f77steve1999-05-241-2/+11 * This port doesn't build with egcs' f77 compiler.steve1999-05-241-2/+7 * Build this port on an Alpha box instead of trying to use i386 binaries.steve1999-05-241-1/+5 * Fix build for Alpha.steve1999-05-241-1/+1 * Fix build on -current (Alpha) machines.steve1999-05-242-18/+29 * Added WWW: for www-site target in DESCRtaoka1999-05-192-2/+2 * Added deft and ortep3taoka1999-05-191-1/+3 * The Oak Ridge Thermal Ellipsoid Plot Program for Crystal Structuretaoka1999-05-197-0/+594 * Density functional molecular orbital calculation.taoka1999-05-197-0/+226 * Fix checksumflathill1999-05-091-1/+1 * Changed MASTER_SITEStaoka1999-05-081-2/+2 * Changed MASTER_SITEStaoka1999-05-081-3/+3 * Add platon and moldentaoka1999-05-071-1/+3 * display molecular orbitals and electron densities in 2D and 3Dtaoka1999-05-077-0/+201 * the one of crystallographic toolstaoka1999-05-076-0/+175 * Be able to use ${PREFIX}taoka1999-05-075-13/+67 * Fixed ${CATEGORIES} (removed misc from it)taoka1999-05-061-2/+2 * Semi-empirical (MNDO, etc.) molecular orbital calculationtaoka1999-05-0611-0/+213 * Plotting wavefunctions (molecular orbitals) in 3Dtaoka1999-05-069-0/+365 * Add mopac and psi88 (Move mopac and psi88 from misc to biology)taoka1999-05-061-1/+3 * Weasal and Wabbits and BIG FOOT.hoek1999-05-036-17/+12 * Upgrade to 2.1.1fenner1999-03-093-8/+16 * Adjust port Makefiles to new EXTRACT_* variable defaults. See log ofasami1999-02-031-1/+3 * Correct the MD5 checksum.vanilla1999-01-31