aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordannyboy <dannyboy@FreeBSD.org>2001-03-17 05:15:50 +0800
committerdannyboy <dannyboy@FreeBSD.org>2001-03-17 05:15:50 +0800
commit1b3b0ecc974d3361c329ad401ab7d98a5addeab9 (patch)
tree36677b164c64b85a3f892d09a5d55c43b72dd625
parent367f942930bc44da9e149d76f36f6cf8bc6cd01c (diff)
downloadfreebsd-ports-gnome-1b3b0ecc974d3361c329ad401ab7d98a5addeab9.tar.gz
freebsd-ports-gnome-1b3b0ecc974d3361c329ad401ab7d98a5addeab9.tar.zst
freebsd-ports-gnome-1b3b0ecc974d3361c329ad401ab7d98a5addeab9.zip
Add mp3chew 0.51.0,
a program to rename mismatched and garbled MP3 filenames. PR: 25653 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3chew/Makefile33
-rw-r--r--audio/mp3chew/distinfo1
-rw-r--r--audio/mp3chew/files/patch-aa15
-rw-r--r--audio/mp3chew/pkg-comment1
-rw-r--r--audio/mp3chew/pkg-descr12
-rw-r--r--audio/mp3chew/pkg-plist6
7 files changed, 69 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index a04be88ae228..0ef0737c3e31 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -99,6 +99,7 @@
SUBDIR += mixer.app
SUBDIR += mp3_check
SUBDIR += mp3blaster
+ SUBDIR += mp3chew
SUBDIR += mp3encode
SUBDIR += mp3info
SUBDIR += mp3rename
diff --git a/audio/mp3chew/Makefile b/audio/mp3chew/Makefile
new file mode 100644
index 000000000000..a109b8683a14
--- /dev/null
+++ b/audio/mp3chew/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mp3chew
+# Date created: 10 March 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3chew
+PORTVERSION= 0.51.0
+CATEGORIES= audio
+MASTER_SITES= http://owl.yi.org/mp3chew/download/tar/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+ALL_TARGET= ${PORTNAME}
+
+DOCFILES= CHANGELOG INSTALL README TODO
+
+post-patch:
+ @${PERL} -pi.fbsd -e 's, _to, to,g' ${WRKSRC}/CMp3Filter.cc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mp3chew ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+.for D in ${DOCFILES}
+ ${MKDIR} ${PREFIX}/share/doc/mp3chew
+ ${INSTALL_DATA} ${WRKSRC}/docs/$D ${PREFIX}/share/doc/mp3chew
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/mp3chew/distinfo b/audio/mp3chew/distinfo
new file mode 100644
index 000000000000..a7fed1f0d42e
--- /dev/null
+++ b/audio/mp3chew/distinfo
@@ -0,0 +1 @@
+MD5 (mp3chew-0.51.0.tar.gz) = c269e484da46699530e55bda90e07a6d
diff --git a/audio/mp3chew/files/patch-aa b/audio/mp3chew/files/patch-aa
new file mode 100644
index 000000000000..7f21d525efff
--- /dev/null
+++ b/audio/mp3chew/files/patch-aa
@@ -0,0 +1,15 @@
+--- Makefile.orig Sat Mar 10 13:43:29 2001
++++ Makefile Sat Mar 10 13:44:01 2001
+@@ -2,10 +2,10 @@
+ TARGET = mp3chew
+ DEPENDS = main.o CMp3Chew.o CMp3Filter.o CMp3SongList.o CMp3Header.o \
+ CMp3Keys.o CMp3Display.o
+-ARGS = -Wall -lpthread -lncurses
++ARGS = -Wall -lc_r -lncurses
+
+ $(TARGET) : $(DEPENDS)
+- $(CC) $(ARGS) -o $(TARGET) $(DEPENDS)
++ $(CC) $(CFLAGS) $(ARGS) -o $(TARGET) $(DEPENDS)
+ @echo
+ @echo "SUCCESS"
+ @echo
diff --git a/audio/mp3chew/pkg-comment b/audio/mp3chew/pkg-comment
new file mode 100644
index 000000000000..ff0f44ed80ff
--- /dev/null
+++ b/audio/mp3chew/pkg-comment
@@ -0,0 +1 @@
+A program to rename mismatched and garbled MP3 filenames
diff --git a/audio/mp3chew/pkg-descr b/audio/mp3chew/pkg-descr
new file mode 100644
index 000000000000..32e9c9e1e5ed
--- /dev/null
+++ b/audio/mp3chew/pkg-descr
@@ -0,0 +1,12 @@
+Mp3Chew is used to alleviate the headaches of mismatched and garbled
+mp3 filenames. It is a console-based application written in C++.
+
+ * Applies various (pre- or user-defined) filters to the filename
+ * Erases ID3 Tags
+ * Creates Song Lists (.m3u's)
+ * Plus a whole bunch more
+
+WWW: http://owl.yi.org/mp3chew/
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/audio/mp3chew/pkg-plist b/audio/mp3chew/pkg-plist
new file mode 100644
index 000000000000..5c7113b9eaeb
--- /dev/null
+++ b/audio/mp3chew/pkg-plist
@@ -0,0 +1,6 @@
+bin/mp3chew
+%%PORTDOCS%%share/doc/mp3chew/CHANGELOG
+%%PORTDOCS%%share/doc/mp3chew/INSTALL
+%%PORTDOCS%%share/doc/mp3chew/README
+%%PORTDOCS%%share/doc/mp3chew/TODO
+%%PORTDOCS%%@dirrm share/doc/mp3chew