aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkientzle <kientzle@FreeBSD.org>2013-07-29 00:58:31 +0800
committerkientzle <kientzle@FreeBSD.org>2013-07-29 00:58:31 +0800
commit2c45fd690a25d01df7d802f8417c03cd3a7bcc7d (patch)
tree9048fc08f7ea3737464930ec5acc33511e9e2a88
parent689766cd7ad24e94476f9ef18d21a8a54b7a12b9 (diff)
downloadfreebsd-ports-gnome-2c45fd690a25d01df7d802f8417c03cd3a7bcc7d.tar.gz
freebsd-ports-gnome-2c45fd690a25d01df7d802f8417c03cd3a7bcc7d.tar.zst
freebsd-ports-gnome-2c45fd690a25d01df7d802f8417c03cd3a7bcc7d.zip
PACKAGE_BUILDING isn't really the right condition here;
what we use as the binutils really depends on whether this is being used as a master port or as a standalone port.
-rw-r--r--devel/cross-gcc/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index f18cdf7cdd1e..dc9200a14d1f 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -22,18 +22,10 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
mpfr.4:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
-#
-# Temporary hack to deal with dependencies during package builds for
-# slave ports.
-#
-.if defined(PACKAGE_BUILDING)
-BUILD_DEPENDS= ${OURTARGET}-as:${PORTSDIR}/devel/${OURTARGET}-binutils
-RUN_DEPENDS= ${OURTARGET}-as:${PORTSDIR}/devel/${OURTARGET}-binutils
-BROKEN= plist build broken with tinderbox/cluster
-.else
-BUILD_DEPENDS= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
-RUN_DEPENDS= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
-.endif
+# If using this as a master port, override BUILD_DEPENDS and
+# RUN_DEPENDS with the appropriate specific binutils port.
+BUILD_DEPENDS?= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
+RUN_DEPENDS?= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
USE_BZIP2= yes
USE_GMAKE= yes