aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-04-22 08:19:42 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-04-22 08:19:42 +0800
commit2c72dd1347c018e36082060fc9a5d2a92c00cd50 (patch)
tree09e528ba009feafe02157948b68ada3331f685c7
parent46c50e1453efbc9440a521922caa32d701d0594a (diff)
downloadfreebsd-ports-gnome-2c72dd1347c018e36082060fc9a5d2a92c00cd50.tar.gz
freebsd-ports-gnome-2c72dd1347c018e36082060fc9a5d2a92c00cd50.tar.zst
freebsd-ports-gnome-2c72dd1347c018e36082060fc9a5d2a92c00cd50.zip
- WITH_APACHE2 is deprecated
- Use SFE macro - Use APACHEMODDIR PR: ports/133684 Approved by: maintainer Submitted by: me
-rw-r--r--www/mod_fcgid/Makefile15
-rw-r--r--www/mod_fcgid/files/pkg-message.in2
-rw-r--r--www/mod_fcgid/pkg-plist2
3 files changed, 9 insertions, 10 deletions
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index 0984ac1c5b0e..32579deea8bd 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -8,7 +8,7 @@
PORTNAME= mod_fcgid
PORTVERSION= 2.2
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITES= SFE
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
DISTNAME= ${PORTNAME}.${PORTVERSION}
@@ -16,24 +16,23 @@ MAINTAINER= hemi@puresimplicity.net
COMMENT= An alternative FastCGI module for Apache2
USE_APACHE= 2.0+
-WITH_APACHE2= yes
SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
.if ${APACHE_VERSION} >= 22
-MAKE_ARGS= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION}"
+MAKE_ARGS+= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION}"
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION} -I${LOCALBASE}/include/apr-1"
INSTALL_TARGET= install-modules-yes
-PLIST_SUB= APACHE_VERSION=${APACHE_VERSION}
-SUB_LIST= APACHE_VERSION=${APACHE_VERSION}
+PLIST_SUB+= APACHE_VERSION=${APACHE_VERSION}
+SUB_LIST+= APACHE_VERSION=${APACHE_VERSION}
.else
-MAKE_ARGS= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION:S/20/2/}"
+MAKE_ARGS+= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION:S/20/2/}"
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION:S/20/2/}"
INSTALL_TARGET= install-modules
-PLIST_SUB= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
-SUB_LIST= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
+PLIST_SUB+= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
+SUB_LIST+= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
.endif
post-install:
diff --git a/www/mod_fcgid/files/pkg-message.in b/www/mod_fcgid/files/pkg-message.in
index 9214400920dc..44a21ca8d934 100644
--- a/www/mod_fcgid/files/pkg-message.in
+++ b/www/mod_fcgid/files/pkg-message.in
@@ -2,7 +2,7 @@
To enable this module, add something like the following
lines to your server configuration file:
- LoadModule fcgid_module libexec/apache%%APACHE_VERSION%%/mod_fcgid.so
+ LoadModule fcgid_module %%APACHEMODDIR%%/mod_fcgid.so
<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
diff --git a/www/mod_fcgid/pkg-plist b/www/mod_fcgid/pkg-plist
index 6dea6aa6ea16..e5008c69d220 100644
--- a/www/mod_fcgid/pkg-plist
+++ b/www/mod_fcgid/pkg-plist
@@ -1,4 +1,4 @@
-libexec/apache%%APACHE_VERSION%%/mod_fcgid.so
+%%APACHEMODDIR%%/mod_fcgid.so
@exec /bin/mkdir -p -m 700 /var/run/fcgidsock
@exec /usr/sbin/chown www:www /var/run/fcgidsock
@unexec /bin/rmdir /var/run/fcgidsock 2>/dev/null || true