aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_fcgid/Makefile15
-rw-r--r--www/mod_fcgid/files/pkg-message.in2
-rw-r--r--www/mod_fcgid/pkg-plist2
3 files changed, 9 insertions, 10 deletions
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index 0984ac1c5b0e..32579deea8bd 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -8,7 +8,7 @@
PORTNAME= mod_fcgid
PORTVERSION= 2.2
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITES= SFE
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
DISTNAME= ${PORTNAME}.${PORTVERSION}
@@ -16,24 +16,23 @@ MAINTAINER= hemi@puresimplicity.net
COMMENT= An alternative FastCGI module for Apache2
USE_APACHE= 2.0+
-WITH_APACHE2= yes
SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
.if ${APACHE_VERSION} >= 22
-MAKE_ARGS= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION}"
+MAKE_ARGS+= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION}"
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION} -I${LOCALBASE}/include/apr-1"
INSTALL_TARGET= install-modules-yes
-PLIST_SUB= APACHE_VERSION=${APACHE_VERSION}
-SUB_LIST= APACHE_VERSION=${APACHE_VERSION}
+PLIST_SUB+= APACHE_VERSION=${APACHE_VERSION}
+SUB_LIST+= APACHE_VERSION=${APACHE_VERSION}
.else
-MAKE_ARGS= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION:S/20/2/}"
+MAKE_ARGS+= top_dir="${LOCALBASE}/share/apache${APACHE_VERSION:S/20/2/}"
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/apache${APACHE_VERSION:S/20/2/}"
INSTALL_TARGET= install-modules
-PLIST_SUB= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
-SUB_LIST= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
+PLIST_SUB+= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
+SUB_LIST+= APACHE_VERSION=${APACHE_VERSION:S/20/2/}
.endif
post-install:
diff --git a/www/mod_fcgid/files/pkg-message.in b/www/mod_fcgid/files/pkg-message.in
index 9214400920dc..44a21ca8d934 100644
--- a/www/mod_fcgid/files/pkg-message.in
+++ b/www/mod_fcgid/files/pkg-message.in
@@ -2,7 +2,7 @@
To enable this module, add something like the following
lines to your server configuration file:
- LoadModule fcgid_module libexec/apache%%APACHE_VERSION%%/mod_fcgid.so
+ LoadModule fcgid_module %%APACHEMODDIR%%/mod_fcgid.so
<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
diff --git a/www/mod_fcgid/pkg-plist b/www/mod_fcgid/pkg-plist
index 6dea6aa6ea16..e5008c69d220 100644
--- a/www/mod_fcgid/pkg-plist
+++ b/www/mod_fcgid/pkg-plist
@@ -1,4 +1,4 @@
-libexec/apache%%APACHE_VERSION%%/mod_fcgid.so
+%%APACHEMODDIR%%/mod_fcgid.so
@exec /bin/mkdir -p -m 700 /var/run/fcgidsock
@exec /usr/sbin/chown www:www /var/run/fcgidsock
@unexec /bin/rmdir /var/run/fcgidsock 2>/dev/null || true
* Note conflict with comms/libcodec2 which is already marked for removaldb2016-10-031-0/+1 * audio/p5-MP3-Tag: update to 1.14novel2016-10-012-4/+4 * Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.tijl2016-10-012-2/+2 * Remove uneeded patch to fix BROKEN.vanilla2016-10-012-17/+0 * audio/darkice: BROKEN (fails to patch now)marino2016-10-011-0/+2 * Only build docs with doxygen inside a DOXYGEN option.mat2016-10-012-6/+6 * Catch stray dependencies, courtesy of the proxy-deps qa check.mat2016-10-011-0/+2 * Chase dependencies affected by the name change devel/google-sparsehash -> dev...matthew2016-09-302-5/+5 * - Update to version 1.1.1, now hosted on GitHubpawel2016-09-303-6/+10 * Update to 0.5.1db2016-09-283-5/+269 * audio/mpg123: update to 1.23.8novel2016-09-283-6/+5 * 1: Upgrade to 1.3.vanilla2016-09-282-18/+12 * - Update devel/doxygen to 1.8.12antoine2016-09-284-4/+6 * - Update devel/icu to 57.1.tijl2016-09-242-1/+2 * Switch to an out-of-source CMake buildrakuco2016-09-241-1/+1 * eSpeak For Asterisk provides the "Espeak" dialplan application,madpilot2016-09-216-0/+117 * Flite For Asterisk provides the "Flite" dialplan application, whichmadpilot2016-09-216-0/+112 * audio/libofa: new fedora MASTER_SITES to unbreakmarino2016-09-211-3/+1 * Add visibility to C++ exceptions to prevent crashes with applicationsjhale2016-09-202-0/+82 * Drop maintainership for xmms and ancillary ports.naddy2016-09-205-5/+5 * audio/mp3blaster: fix build with Clang 3.9emaste2016-09-201-0/+11 * - Unbreak fetching by pointing to archived distfile in Google Cloud Storagedanfe2016-09-181-7/+1 * audio/ruby-mp3tag: remove unneeded USE_RUBY_RDOCswills2016-09-171-1/+0 * - Update to 0.12amdmi32016-09-172-5/+5 * Convert to options helperspawel2016-09-161-87/+57 * audio/ruby-taglib: remove use of RUBY_RD_FILESswills2016-09-151-5/+3 * audio/ruby-mp3tag: remove use of RUBY_RD_FILESswills2016-09-152-7/+2 * Do not include bsd.port.pre.mk twiceantoine2016-09-151-1/+1 * Unmark broken on powerpc64swills2016-09-151-2/+0 * GOOGLE_CODE has gone away.mat2016-09-1411-0/+22 * - Fix LICENSEamdmi32016-09-141-2/+4 * audio/simon -- Remove INSTALLS_ICONS and make stage-qa happytcberner2016-09-131-3/+4 * Fix build of audio/clementine-player with clang 3.9.0dim2016-09-131-0/+6 * Update to upstream version 3.0.13.4riggs2016-09-103-9/+10 * Most commonly used build systems support silent builds, when theyamdmi32016-09-105-6/+2 * - Fix build with --disable-silent-rulesamdmi32016-09-101-0/+10 * audio/re: Set to use correct openssl headersmarino2016-09-101-2/+2 * - In Uses/linux.mk use the loop variable directly when appending totijl2016-09-0711-7/+11 * audio/mpg123: add SNDIO option and cleanupsnovel2016-09-072-5/+14 * - Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk withtijl2016-09-0642-185/+112 * audio/gmpc(-magnatune): revbump required after previous changesmarino2016-09-012-2/+2 * - Update to 0.2~beta2amdmi32016-08-293-12/+17 * audio/openal-soft: re-apply r420906pi2016-08-271-2/+2 * - Convert to USES=sqlitepawel2016-08-262-5/+7 * audio/openal-soft: Add option to enable sndio supportpi2016-08-261-2/+5 * - Convert to USES=localbase sqlitepawel2016-08-261-6/+10 * audio/openal-soft: fix missing QT4 dependenciesnovel2016-08-261-1/+1 * audio/cmus: 2.6.0 -> 2.7.1pi2016-08-269-261/+211 * Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks andtcberner2016-08-2415-30/+31 * audio/zinf: document ncurses requirementmarino2016-08-2416-7/+151 * Update to version 0.28pawel2016-08-242-4/+5 * audio/umix: document ncurses requirementmarino2016-08-241-0/+1 * audio/ufmcontrol-i18n: mark broken (unfetchable)marino2016-08-241-0/+2 * audio/mp3info: document and fix ncurses requirementmarino2016-08-242-3/+5 * audio/herrie: document ncurses requirementmarino2016-08-241-1/+1 * audio/alsa-utils: document ncurses requirementmarino2016-08-241-1/+1 * - Update to 0.7.5amdmi32016-08-232-14/+10 * Revive audio/exaile-develrm2016-08-216-0/+1113 * audio/py-mutagen: add missing shebangfixrm2016-08-211-2/+2 * - Fix high CPU usage while recording and playing at the same time,pawel2016-08-206-215/+181 * - Update to 0.4.2amdmi32016-08-203-4/+5 * - Update to 0.25amdmi32016-08-202-6/+7 * A module for PulseAudio to support playing to sndio servers.pawel2016-08-195-0/+46 * The aucatctl utility sends MIDI messages to control sndiod and/orpawel2016-08-194-0/+37 * audio/teamspeak3-server: 3.0.13 -> 3.0.13.2pi2016-08-173-11/+11 * Add python3 version of audio/py-mutagen packagerm2016-08-162-0/+8 * audio/py-mutagen: small changesrm2016-08-162-13/+8 * audio/teamspeak3-server: mention path to ini-file in pkg-message.inpi2016-08-152-2/+4 * Update to 1.34.1olivierd2016-08-152-4/+4 * - Update to version 1.3.19pawel2016-08-122-7/+9 * - drop maintainership cause of r394778dinoex2016-08-121-1/+1 * Enable sndio support in libao, based on the OpenBSD port.naddy2016-08-093-1/+64 * Pacify stage-qaehaupt2016-08-092-7/+15 * Strip binaryehaupt2016-08-091-1/+4 * audio/teamspeak3-server: 3.0.12.4 -> 3.0.13pi2016-08-094-5/+30 * Update to 1.34olivierd2016-08-092-4/+4 * USE_BDB cleanup.mat2016-08-082-4/+2 * - Register gettext-runtime USESehaupt2016-08-081-2/+4 * - Strip libraryehaupt2016-08-081-3/+6 * Use INSTALL_LIB instead of INSTALL_DATAehaupt2016-08-081-2/+2 * - Strip libraryehaupt2016-08-081-2/+7 * - Register gettext-runtime USESehaupt2016-08-082-4/+5 * - Strip binariesehaupt2016-08-081-2/+5 * Strip binariesehaupt2016-08-081-1/+3 * Register x11, xext and xv in USE_XORGehaupt2016-08-081-1/+2 * Strip libraryehaupt2016-08-081-1/+3 * Set DISTNAME to PORTNAME.kevlo2016-08-051-2/+1 * Add a conditional depends on devel/py-monotonic for faster operations inkevlo2016-08-051-2/+7 * audio/alsa-{lib,utils}: update to 1.1.2jbeich2016-08-057-11/+38 * - Fix build on FreeBSD 9.xpawel2016-08-042-7/+4 * Update to 1.1.3 for some minor fixes.naddy2016-08-043-4/+5 * Import SpeechRecognition 3.4.6kevlo2016-08-044-0/+32 * Support hw.snd.default_unit sysctl.kevlo2016-08-042-1/+36 * audio/libamr(n|w)b: Remove redundant dependency on unzipmarino2016-08-042-4/+0 * Update midip to 1.3.2.kwm2016-08-042-3/+4 * audio/cplay: Update to 1.50woodsb022016-08-038-130/+73 * New port: audio/sndiopi2016-08-0312-0/+1153 * Remove p5-IO-Socket-IP dependency and bump PORTREVISION.adamw2016-08-031-1/+1 * Use LINUX_REPO_ARCH instead of LINUX_RPM_ARCH when setting DISTINFO_FILEtijl2016-08-0134-0/+0 * Remove build dependency on bison, it actually works perfectly yaccbapt2016-08-011-2/+0 * Fix build, using getline(3) from libcantoine2016-07-318-229/+10 * Upgrade to 1.0.2.sobomax2016-07-303-5/+11 * Oops, fix CATEGORY to match.sobomax2016-07-301-1/+1 * Add libg722, a software G.722 decoding/encoding library that issobomax2016-07-305-0/+45 * Prevent collision with getline(3)bapt2016-07-302-2/+2 * audio/teamspeak3-server: Mark BROKEN on 11, will not startpi2016-07-301-0/+2 * - Update to version 0.7.0 [1]pawel2016-07-291-1/+1 * Cleanup patches, a* categories.mat2016-07-271044-4663/+4351 * audio/libaudiofile: track flac dependencyjbeich2016-07-261-1/+3 * Reset miwi@'s ports, he stepped down from the Ports Team.rene2016-07-261-1/+1 * - Update to version 0.47.1pawel2016-07-252-4/+5 * Update to 4.1.0ehaupt2016-07-222-3/+4 * Update to 4.4.0ehaupt2016-07-222-3/+4 * Cleanup $() variables in ports Makefiles.mat2016-07-201-1/+1 * - update libgd to 2.2.2dinoex2016-07-202-2/+2 * When there is a do-install target, do not use a post-install target, domat2016-07-194-6/+2 * audio/soundkonverter: remove INSTALLS_ICONS, fix plist.dbn2016-07-192-2/+2 * Don't echo in post-install, use pkg-message. Also, don't "fix"mat2016-07-192-11/+7 * audio/soundkonverter: update to 2.2.2dbn2016-07-144-34/+15 * - Update to 0.8amdmi32016-07-134-15/+19 * audio/portaudio: fix test program installationpi2016-07-101-2/+3 * - Update to 2016.06.02kmoore2016-07-092-3/+3 * Bump PORTREVISION for the icu revert.mat2016-07-071-1/+1 * - Update to 1.33.2olivierd2016-07-073-5/+5 * devel/icu: bump PORTREVISION on dependent portsgahr2016-07-061-1/+1 * Update to 0.05.mat2016-07-052-4/+4 * Remove expired ports without open PRs:rene2016-07-0519-644/+0 * Update MASTER_SITES, minor cleanup.mat2016-07-041-5/+3 * audio/lastfm-desktop: Update to 2.1.36woodsb022016-07-048-63/+307 * - Update to 0.04wen2016-07-033-9/+9 * Update to 1.33.1olivierd2016-07-022-3/+4 * audio/mpg123: update to 1.23.6novel2016-07-022-3/+4 * This is a Fluid (R3) General MIDI soundfonts, for use with any modern MIDIdanfe2016-07-026-0/+2977 * - Add new MASTER_SITE and unbreak [1]madpilot2016-07-022-4/+3 * - Update to 0.2.3olivierd2016-07-018-154/+19 * Convert a couple ports that use both _CMAKE_ON and _CMAKE_OFF to _CMAKE_BOOL.adamw2016-07-01