aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-10-05 08:07:58 +0800
committerwg <wg@FreeBSD.org>2014-10-05 08:07:58 +0800
commit6f78cadc9523062ed61e7cb22ed7245c0b3ec353 (patch)
tree84aedd83c438c4ec4944f35ba57aeaa37b20bb96
parent505f5851f35c2bdacabadf9bdbd26eecc895d7a3 (diff)
downloadfreebsd-ports-gnome-6f78cadc9523062ed61e7cb22ed7245c0b3ec353.tar.gz
freebsd-ports-gnome-6f78cadc9523062ed61e7cb22ed7245c0b3ec353.tar.zst
freebsd-ports-gnome-6f78cadc9523062ed61e7cb22ed7245c0b3ec353.zip
graphics/py-soya3d: switch from py-imaging to py-pillow
- USES python With hat: python Approved by: portmgr (bdrewery, implicit)
-rw-r--r--graphics/py-soya3d/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index c6246bb80358..51a82a5ef870 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -3,7 +3,7 @@
PORTNAME= soya3d
PORTVERSION= 0.14
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics python
MASTER_SITES= http://download.gna.org/soya/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,18 +15,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Very high level 3D engine for Python
BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode \
- ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
LIB_DEPENDS= libcal3d.so:${PORTSDIR}/graphics/cal3d \
libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/editobj/editor.py:${PORTSDIR}/graphics/py-editobj \
${PYTHON_SITELIBDIR}/tofu/client.py:${PORTSDIR}/net/py-tofu \
${PYTHON_SITELIBDIR}/cerealizer/__init__.py:${PORTSDIR}/security/py-cerealizer
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-USES= gmake openal:al,alut tar:bzip2
+USES= gmake openal:al,alut python tar:bzip2
USE_GL= glew glu
+USE_PYTHON= autoplist distutils
USE_SDL= sdl
LDFLAGS+= -L${LOCALBASE}/lib -lGLU