aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-24 09:09:24 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-24 09:09:24 +0800
commit71ffff057f084a8ed1851ae154d458d4580de09f (patch)
tree0363dbd56518fdd4bc393b050babf46848e607c4
parentc1d7571329b518aa8afc253455cc7b5750c3c111 (diff)
downloadfreebsd-ports-gnome-71ffff057f084a8ed1851ae154d458d4580de09f.tar.gz
freebsd-ports-gnome-71ffff057f084a8ed1851ae154d458d4580de09f.tar.zst
freebsd-ports-gnome-71ffff057f084a8ed1851ae154d458d4580de09f.zip
- Bump PORTREVISION
- Change Desktop entry file - Remove not needed MKDIR - Adjust patches, fix usage with nvidia cards PR: ports/187688, ports/186565 Submitted by: Nikolai Lifanov <lifanov@mail.lifanov.com>, "Mikhail T." <m.tsatsenko@gmail.com>
-rw-r--r--games/tome4/Makefile13
-rw-r--r--games/tome4/files/patch-build__te4core.lua11
-rw-r--r--games/tome4/files/patch-premake4.lua12
3 files changed, 16 insertions, 20 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index 7fa6215aaf42..377be4b4216e 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tome4
PORTVERSION= 1.1.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://te4.org/dl/t-engine/ \
SF/lifanov-ports-icons/${PORTNAME}/:icons
@@ -18,8 +19,8 @@ LICENSE= GPLv3
BUILD_DEPENDS= premake4:${PORTSDIR}/devel/premake4
LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
-DESKTOP_ENTRIES="ToME 4" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;RolePlaying;" false
+DESKTOP_ENTRIES="ToME 4" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;RolePlaying;" ""
WRKSRC= ${WRKDIR}/t-engine4-src-${PORTVERSION}
MAKE_ARGS+= config=release verbose=yes ARCH=""
@@ -27,19 +28,17 @@ USES= gmake openal:al tar:bzip2
USE_SDL= image2 sdl2 ttf2
USE_GL= gl
SUB_FILES= tome4
-
MAKE_JOBS_UNSAFE=yes
pre-build:
- (cd ${WRKSRC}; premake4 gmake)
+ (cd ${WRKSRC} && premake4 gmake)
@${REINPLACE_CMD} 's|-lpthread|-pthread|' ${WRKSRC}/build/TEngine.make
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/t-engine ${STAGEDIR}${DATADIR}
- ${INSTALL} -m 0755 ${WRKDIR}/tome4 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL} -m 0755 ${WRKDIR}/tome4 ${STAGEDIR}${PREFIX}/bin/
(cd ${WRKSRC}; ${COPYTREE_SHARE} "bootstrap game" ${STAGEDIR}${DATADIR})
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
diff --git a/games/tome4/files/patch-build__te4core.lua b/games/tome4/files/patch-build__te4core.lua
index f617ce2cba5b..75225fa254af 100644
--- a/games/tome4/files/patch-build__te4core.lua
+++ b/games/tome4/files/patch-build__te4core.lua
@@ -1,14 +1,5 @@
--- ./build/te4core.lua.orig 2014-01-05 19:42:37.000000000 -0500
-+++ ./build/te4core.lua 2014-02-06 13:23:22.476164878 -0500
-@@ -109,7 +109,7 @@
-
- configuration "bsd"
- libdirs {"/usr/local/lib/"}
-- links { "SDL2", "SDL2_ttf", "SDL2_image", "png", "openal", "vorbisfile", "GL", "GLU", "m", "pthread" }
-+ links { "SDL2", "SDL2_ttf", "SDL2_image", "png", "openal", "vorbisfile", "GL", "GLU", "m" }
- defines { [[TENGINE_HOME_PATH='".t-engine"']], 'SELFEXE_BSD' }
-
- configuration {"Debug"}
++++ ./build/te4core.lua 2014-01-05 19:42:37.000000000 -0500
@@ -159,7 +159,7 @@
files { "../src/luajit2/src/host/minilua.c" }
diff --git a/games/tome4/files/patch-premake4.lua b/games/tome4/files/patch-premake4.lua
index 7f9aa553094b..ecaf698b822e 100644
--- a/games/tome4/files/patch-premake4.lua
+++ b/games/tome4/files/patch-premake4.lua
@@ -1,6 +1,12 @@
---- ./premake4.lua.orig 2014-02-06 13:23:35.469164876 -0500
-+++ ./premake4.lua 2014-02-06 13:34:48.071117476 -0500
-@@ -35,6 +35,9 @@
+--- ./premake4.lua.orig 2014-01-06 20:04:42.000000000 -0500
++++ ./premake4.lua 2014-03-23 19:34:38.037102075 -0400
+@@ -30,11 +30,14 @@
+
+ configuration "bsd"
+ libdirs {
+- "/usr/local/lib",
++ "bin/Release", "/usr/local/lib",
+ }
includedirs {
"/usr/local/include",
}