aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-08-13 03:15:11 +0800
committerjbeich <jbeich@FreeBSD.org>2019-08-13 03:15:11 +0800
commit844420ff1cf7bedd5d2e1810cb3bb8d4e2f291a1 (patch)
treeed783c047b70c34113051322e61b5de27a411e50
parenta5850abf53650c7c8f6bfe5421746049dbeaed0f (diff)
downloadfreebsd-ports-gnome-844420ff1cf7bedd5d2e1810cb3bb8d4e2f291a1.tar.gz
freebsd-ports-gnome-844420ff1cf7bedd5d2e1810cb3bb8d4e2f291a1.tar.zst
freebsd-ports-gnome-844420ff1cf7bedd5d2e1810cb3bb8d4e2f291a1.zip
x11/wev: add new port
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wev/Makefile29
-rw-r--r--x11/wev/distinfo3
-rw-r--r--x11/wev/pkg-descr4
4 files changed, 37 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index cbe49044d0db..02fb0c38f0b7 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -336,6 +336,7 @@
SUBDIR += wbar
SUBDIR += wbarconf
SUBDIR += wdm
+ SUBDIR += wev
SUBDIR += wf-shell
SUBDIR += wl-clipboard
SUBDIR += wmappl
diff --git a/x11/wev/Makefile b/x11/wev/Makefile
new file mode 100644
index 000000000000..1ae475dd857d
--- /dev/null
+++ b/x11/wev/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= wev
+PORTVERSION= s20190811
+DISTVERSIONSUFFIX= -0-g47d1739
+CATEGORIES= x11
+MASTER_SITES= https://git.sr.ht/~sircmpwn/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wayland event viewer
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ wayland-protocols>0:graphics/wayland-protocols \
+ scdoc:textproc/scdoc
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gmake pkgconfig
+MAKE_ENV= MANDIR='$$(PREFIX)/man'
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/ -lrt//' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/x11/wev/distinfo b/x11/wev/distinfo
new file mode 100644
index 000000000000..482080c6b04b
--- /dev/null
+++ b/x11/wev/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565511866
+SHA256 (wev-s20190811-0-g47d1739.tar.gz) = 33e6210a0fbd5527a60303ddd33b2b1a445c9c6f49ed5e236369ce692814fcb6
+SIZE (wev-s20190811-0-g47d1739.tar.gz) = 7766
diff --git a/x11/wev/pkg-descr b/x11/wev/pkg-descr
new file mode 100644
index 000000000000..0b68c5321326
--- /dev/null
+++ b/x11/wev/pkg-descr
@@ -0,0 +1,4 @@
+This is a tool for debugging events on a Wayland window, analagous to
+the X11 tool xev.
+
+WWW: https://git.sr.ht/~sircmpwn/wev