aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-03-22 00:40:38 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 20:02:55 +0800
commit925f8dd811454793f42c72d77f03f4d71273cb2d (patch)
tree7b8405efb3b0b48248cc12b794e435ca3ac0703f
parent2bbd8c58e41116b4a6ce02b2720abec51de791b3 (diff)
downloadfreebsd-ports-gnome-925f8dd811454793f42c72d77f03f4d71273cb2d.tar.gz
freebsd-ports-gnome-925f8dd811454793f42c72d77f03f4d71273cb2d.tar.zst
freebsd-ports-gnome-925f8dd811454793f42c72d77f03f4d71273cb2d.zip
www/gitlab: fix wrong detection of running Sidekiq
Sidekiq is detected as "not running" because when checking with "ps" it does not account for column truncation PR: 209487 Submitted by: Chris Stankevitz <chris-freebsd-bugs@stankevitz.com> Reported by: otacilio.neto@bsd.com.br Reviewed by: Matthias Fechner <idefix@fechner.net>
-rw-r--r--www/gitlab/Makefile2
-rw-r--r--www/gitlab/files/patch-lib_tasks_gitlab_check.rake11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/gitlab/Makefile b/www/gitlab/Makefile
index 52440518591e..1843cfb63931 100644
--- a/www/gitlab/Makefile
+++ b/www/gitlab/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gitlab
PORTVERSION= 8.14.9
DISTVERSIONPREFIX= v
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www devel
MAINTAINER= tz@FreeBSD.org
diff --git a/www/gitlab/files/patch-lib_tasks_gitlab_check.rake b/www/gitlab/files/patch-lib_tasks_gitlab_check.rake
new file mode 100644
index 000000000000..89a814df822d
--- /dev/null
+++ b/www/gitlab/files/patch-lib_tasks_gitlab_check.rake
@@ -0,0 +1,11 @@
+--- lib/tasks/gitlab/check.rake.orig 2017-03-21 16:35:39 UTC
++++ lib/tasks/gitlab/check.rake
+@@ -621,7 +621,7 @@ namespace :gitlab do
+ end
+
+ def sidekiq_process_count
+- ps_ux, _ = Gitlab::Popen.popen(%W(ps ux))
++ ps_ux, _ = Gitlab::Popen.popen(%W(ps wux))
+ ps_ux.scan(/sidekiq \d+\.\d+\.\d+/).count
+ end
+ end