aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/gitlab/Makefile2
-rw-r--r--www/gitlab/files/patch-lib_tasks_gitlab_check.rake11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/gitlab/Makefile b/www/gitlab/Makefile
index 52440518591e..1843cfb63931 100644
--- a/www/gitlab/Makefile
+++ b/www/gitlab/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gitlab
PORTVERSION= 8.14.9
DISTVERSIONPREFIX= v
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www devel
MAINTAINER= tz@FreeBSD.org
diff --git a/www/gitlab/files/patch-lib_tasks_gitlab_check.rake b/www/gitlab/files/patch-lib_tasks_gitlab_check.rake
new file mode 100644
index 000000000000..89a814df822d
--- /dev/null
+++ b/www/gitlab/files/patch-lib_tasks_gitlab_check.rake
@@ -0,0 +1,11 @@
+--- lib/tasks/gitlab/check.rake.orig 2017-03-21 16:35:39 UTC
++++ lib/tasks/gitlab/check.rake
+@@ -621,7 +621,7 @@ namespace :gitlab do
+ end
+
+ def sidekiq_process_count
+- ps_ux, _ = Gitlab::Popen.popen(%W(ps ux))
++ ps_ux, _ = Gitlab::Popen.popen(%W(ps wux))
+ ps_ux.scan(/sidekiq \d+\.\d+\.\d+/).count
+ end
+ end