aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-04-12 15:03:19 +0800
committermarino <marino@FreeBSD.org>2015-04-12 15:03:19 +0800
commit96af59f4378c06714e77f0bde2cd7a6ec8955a89 (patch)
tree3ba1e5055fd9fd6ad56b8fdc9a3444bd51b1d84b
parent58a1f8c9e698dbb375938eb96889490ecc8ac15f (diff)
downloadfreebsd-ports-gnome-96af59f4378c06714e77f0bde2cd7a6ec8955a89.tar.gz
freebsd-ports-gnome-96af59f4378c06714e77f0bde2cd7a6ec8955a89.tar.zst
freebsd-ports-gnome-96af59f4378c06714e77f0bde2cd7a6ec8955a89.zip
x11-toolkits/py-wxPython30: Unbreak on F10
It turns out that wxPython30 won't build with clang at all. The c++ code is illegal according to clang (e.g. illegal cast), so remove the USES=compiler setting and replace with USE_GCC=yes. Tested on F8 and F10. I apologize for adding the GCC dependence for F10+ users but I didn't see any other simple fix. Approved by: blanket
-rw-r--r--x11-toolkits/py-wxPython30/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-toolkits/py-wxPython30/Makefile b/x11-toolkits/py-wxPython30/Makefile
index 1f20f540f4df..5f8c74fccae5 100644
--- a/x11-toolkits/py-wxPython30/Makefile
+++ b/x11-toolkits/py-wxPython30/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wxPython
PORTVERSION= 3.0.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits python
MASTER_SITES= SF/wxpython/wxPython/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ DIST_SUBDIR= python
WRKSRC= ${WRKDIR}/${DISTNAME}/wxPython
-USES= compiler:c++11-lib python tar:bzip2
+USES= python tar:bzip2
.if defined(WITH_WXVERSION_ONLY)
@@ -41,7 +41,8 @@ WX_PYTHON_DIR= wx-${WX_VERSION}-${WXPORT}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wxPython-common>0:${PORTSDIR}/x11-toolkits/py-wxPython-common
USES+= gettext pkgconfig
-USE_WX= 3.0
+USE_WX= 3.0
+USE_GCC= yes
WANT_UNICODE= yes
USE_PYTHON= distutils autoplist
PYDISTUTILS_BUILDARGS= WX_CONFIG="${WX_CONFIG}" \