aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-09-08 01:51:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-09-08 01:51:39 +0800
commitc64a09ed38be3a5fa6c13d5bbc184940888895b4 (patch)
tree0877850181d1b1ff5c96c6d6c7293fddfeab2b2d
parent28d15466ecb04dd03d30e52d3d974b34b80da033 (diff)
downloadfreebsd-ports-gnome-c64a09ed38be3a5fa6c13d5bbc184940888895b4.tar.gz
freebsd-ports-gnome-c64a09ed38be3a5fa6c13d5bbc184940888895b4.tar.zst
freebsd-ports-gnome-c64a09ed38be3a5fa6c13d5bbc184940888895b4.zip
- Add VALA option
- Bump PORTREVISION for package change
-rw-r--r--net/gupnp-av/Makefile10
-rw-r--r--net/gupnp-av/pkg-plist2
2 files changed, 11 insertions, 1 deletions
diff --git a/net/gupnp-av/Makefile b/net/gupnp-av/Makefile
index 00e042e08843..dd6e82daf871 100644
--- a/net/gupnp-av/Makefile
+++ b/net/gupnp-av/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gupnp-av
PORTVERSION= 0.12.7
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= GNOME
@@ -16,8 +17,11 @@ BUILD_DEPENDS= gobject-introspection>=0.9.5:${PORTSDIR}/devel/gobject-introspect
LIB_DEPENDS= libgupnp-1.0.so:${PORTSDIR}/net/gupnp
RUN_DEPENDS= gupnp>=0.19.0:${PORTSDIR}/net/gupnp
+OPTIONS_DEFINE= VALA
+OPTIONS_SUB= yes
+VALA_DESC= Vala binding (requires net/gssdp and net/gupnp with VALA enabled)
+
CONFIGURE_ARGS= --enable-introspection=yes
-CONFIGURE_ENV= VAPIGEN="" ac_cv_path_VAPIGEN=""
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_GNOME= glib20 introspection:build
@@ -26,6 +30,10 @@ USES= gmake libtool pathfix pkgconfig tar:xz
PORTDATA= *
+VALA_BUILD_DEPENDS= vala>=0.22:${PORTSDIR}/lang/vala
+VALA_CONFIGURE_ENV= ac_cv_path_VAPIGEN=${LOCALBASE}/bin/vapigen
+VALA_CONFIGURE_ENV_OFF= ac_cv_path_VAPIGEN=""
+
post-patch:
@${REINPLACE_CMD} -e 's|-Wno-unused-parameters||' ${WRKSRC}/tests/Makefile.in
diff --git a/net/gupnp-av/pkg-plist b/net/gupnp-av/pkg-plist
index beb826fa565f..d90ec7b3b141 100644
--- a/net/gupnp-av/pkg-plist
+++ b/net/gupnp-av/pkg-plist
@@ -56,3 +56,5 @@ share/gtk-doc/html/gupnp-av/right-insensitive.png
share/gtk-doc/html/gupnp-av/style.css
share/gtk-doc/html/gupnp-av/up.png
share/gtk-doc/html/gupnp-av/up-insensitive.png
+%%VALA%%share/vala/vapi/gupnp-av-1.0.deps
+%%VALA%%share/vala/vapi/gupnp-av-1.0.vapi