aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2009-06-02 03:02:37 +0800
committernox <nox@FreeBSD.org>2009-06-02 03:02:37 +0800
commitcb7b1c4122bf6b208ff8dfd12b9864b5b355b83f (patch)
tree9d2d1f2f9d869695024795835c55f07b45efa259
parent97e00baf24ed270dd1bf9e3b2c5333bf943d413a (diff)
downloadfreebsd-ports-gnome-cb7b1c4122bf6b208ff8dfd12b9864b5b355b83f.tar.gz
freebsd-ports-gnome-cb7b1c4122bf6b208ff8dfd12b9864b5b355b83f.tar.zst
freebsd-ports-gnome-cb7b1c4122bf6b208ff8dfd12b9864b5b355b83f.zip
- (Attempt to) fix build on head by entirely disabling the usb host code
which is still not ported to the new usb stack yet. (qemu could really use some help here, the author of the old usb host code is busy with other stuff now...) - No PORTREVISION bump since this is a build fix.
-rw-r--r--emulators/qemu-devel/Makefile9
-rw-r--r--emulators/qemu/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index b5797246050a..9b6aced13ecc 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -124,6 +124,15 @@ post-patch:
-e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
${WRKSRC}/texi2pod.pl
+.if ${OSVERSION} >= 800091
+# XXX need to disable usb host code on head while it's not ported to the
+# new usb stack yet
+post-configure:
+ @${REINPLACE_CMD} -E \
+ -e "s|^(HOST_USB=)bsd|\1stub|" \
+ ${WRKSRC}/config-host.mak
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 6c538c1b798a..6a302490c036 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -125,6 +125,15 @@ post-patch:
-e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
${WRKSRC}/texi2pod.pl
+.if ${OSVERSION} >= 800091
+# XXX need to disable usb host code on head while it's not ported to the
+# new usb stack yet
+post-configure:
+ @${REINPLACE_CMD} -E \
+ -e "s|^(HOST_USB=)bsd|\1stub|" \
+ ${WRKSRC}/config-host.mak
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc