aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/qemu-devel/Makefile9
-rw-r--r--emulators/qemu/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index b5797246050a..9b6aced13ecc 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -124,6 +124,15 @@ post-patch:
-e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
${WRKSRC}/texi2pod.pl
+.if ${OSVERSION} >= 800091
+# XXX need to disable usb host code on head while it's not ported to the
+# new usb stack yet
+post-configure:
+ @${REINPLACE_CMD} -E \
+ -e "s|^(HOST_USB=)bsd|\1stub|" \
+ ${WRKSRC}/config-host.mak
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 6c538c1b798a..6a302490c036 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -125,6 +125,15 @@ post-patch:
-e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
${WRKSRC}/texi2pod.pl
+.if ${OSVERSION} >= 800091
+# XXX need to disable usb host code on head while it's not ported to the
+# new usb stack yet
+post-configure:
+ @${REINPLACE_CMD} -E \
+ -e "s|^(HOST_USB=)bsd|\1stub|" \
+ ${WRKSRC}/config-host.mak
+.endif
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${PREFIX}/etc