aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-07-09 10:24:04 +0800
committerclsung <clsung@FreeBSD.org>2007-07-09 10:24:04 +0800
commite048a906518a1ec7c91c5d2108570e139771e39f (patch)
tree4388bb2b734535364c2cf0009e18757678904316
parentc651d57893c616f57be211f21d31c83fe79a8bf6 (diff)
downloadfreebsd-ports-gnome-e048a906518a1ec7c91c5d2108570e139771e39f.tar.gz
freebsd-ports-gnome-e048a906518a1ec7c91c5d2108570e139771e39f.tar.zst
freebsd-ports-gnome-e048a906518a1ec7c91c5d2108570e139771e39f.zip
ZXID aims at full stack implementation of all federated identity
management and identity web services protocols. Initial goal is supporting SP role, followed by ID-WSF WSC and IdP roles. ZXID is light weight, has a small foot print, and is implemented in C. It is suitable for both high performance and embedded applications. Scripting languages are supported using SWIG, including Perl, PHP and Java. The "full stack" nature of ZXID means it's self contained and has minimal external library dependencies (see downloads). WWW: http://zxid.org/ PR: ports/114346 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--security/Makefile1
-rw-r--r--security/zxid/Makefile25
-rw-r--r--security/zxid/distinfo3
-rw-r--r--security/zxid/files/patch-Makefile55
-rw-r--r--security/zxid/files/patch-zxlib.c10
-rw-r--r--security/zxid/pkg-descr11
-rw-r--r--security/zxid/pkg-plist61
7 files changed, 166 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7d81e4839317..eb01510d27a3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -762,6 +762,7 @@
SUBDIR += yersinia
SUBDIR += zebedee
SUBDIR += zombiezapper
+ SUBDIR += zxid
SUBDIR += zzuf
.include <bsd.port.subdir.mk>
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
new file mode 100644
index 000000000000..5aa68f862e00
--- /dev/null
+++ b/security/zxid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: zxid
+# Date created: 2007-07-06
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zxid
+PORTVERSION= 0.17
+CATEGORIES= security www
+MASTER_SITES= http://zxid.org/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Open Source IdM for the Masses - SAML SSO
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+MAKE_ARGS+= CC="${CC}" CURL_ROOT="${LOCALBASE}" LD="${CC}" \
+ PREFIX="${PREFIX}" OPENSSL_ROOT="${OPENSSLBASE}"
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+
+.include <bsd.port.mk>
diff --git a/security/zxid/distinfo b/security/zxid/distinfo
new file mode 100644
index 000000000000..4f364d34c314
--- /dev/null
+++ b/security/zxid/distinfo
@@ -0,0 +1,3 @@
+MD5 (zxid-0.17.tgz) = 003890574bfba88a2c7c7a4eb5f0b937
+SHA256 (zxid-0.17.tgz) = 4dc6e2421624b5e4264fd79e2047d440ba1b3b6d75464033f5ef0bd5c395dde9
+SIZE (zxid-0.17.tgz) = 1968624
diff --git a/security/zxid/files/patch-Makefile b/security/zxid/files/patch-Makefile
new file mode 100644
index 000000000000..ec3b15790b10
--- /dev/null
+++ b/security/zxid/files/patch-Makefile
@@ -0,0 +1,55 @@
+--- Makefile.orig Tue Mar 6 15:11:03 2007
++++ Makefile Fri Jul 6 06:58:52 2007
+@@ -24,13 +24,13 @@
+
+ default: seehelp zxid zxidhlo zxidhlowsf zxidsimple zxidwsctool zxlogview
+
+-all: seehelp zxid zxidhlo zxidsimple zxlogview samlmod phpzxid javazxid
++all: seehelp zxid zxidhlo zxidsimple zxlogview
+
+ ZXIDREL=0.17
+ ZXIDVERSION=0x000017
+
+ ### Where package is installed (use `make PREFIX=/your/path' to change)
+-PREFIX=/usr/local/zxid/$(ZXIDREL)
++PREFIX?=/usr/local/zxid/$(ZXIDREL)
+
+ ### Where runtime configuration and temporary data is kept.
+ ### If you change the following, be sure to edit zxidconf.h as well. N.B. Trailing / is needed.
+@@ -58,8 +58,8 @@
+ ###
+
+ TOP=$(shell pwd)
+-CURL_ROOT=/usr/local
+-OPENSSL_ROOT=/usr/local/ssl
++CURL_ROOT?=/usr/local
++OPENSSL_ROOT?=/usr/local/ssl
+ PHP_CONFIG=php-config
+ PERL=perl
+ XSD2SG_PL= ../pd/xsd2sg.pl
+@@ -69,11 +69,11 @@
+ SWIG=swig
+ AR=ar -crs
+ ARX=ar -x
+-CC=gcc
+-LD=gcc
+-SHARED_FLAGS=-shared --export-all-symbols -Wl,-whole-archive -Wl,--allow-multiple-definition
+-SHARED_CLOSE=-Wl,-no-whole-archive
+-CFLAGS=-g -fpic -fmessage-length=0 -Wno-unused-label -Wno-unknown-pragmas -fno-strict-aliasing
++CC?=gcc
++LD?=gcc
++SHARED_FLAGS+=-shared --export-all-symbols -Wl,-whole-archive -Wl,--allow-multiple-definition
++SHARED_CLOSE+=-Wl,-no-whole-archive
++CFLAGS+=-g -fpic -fmessage-length=0 -Wno-unused-label -Wno-unknown-pragmas -fno-strict-aliasing
+ #CFLAGS += -Os # gcc-3.4.6 miscompiles with -Os on ix86
+ #CFLAGS += -Wall
+
+@@ -105,7 +105,7 @@
+ CDEF+= -DUSE_CURL
+ # Without OpenSSL signing and signature verification are not possible
+ CDEF+= -DUSE_OPENSSL
+-LIBS=-lpthread -L$(CURL_ROOT)/lib -L$(OPENSSL_ROOT)/lib -lcrypto -ldl -lcurl -lz
++LIBS=-lpthread -L$(CURL_ROOT)/lib -L$(OPENSSL_ROOT)/lib -lcrypto -lcurl -lz
+
+ # Following ld flags as well as C flag -ffunction-sections are a quest to
+ # eliminate unused functions from final link.
diff --git a/security/zxid/files/patch-zxlib.c b/security/zxid/files/patch-zxlib.c
new file mode 100644
index 000000000000..1e75c4615760
--- /dev/null
+++ b/security/zxid/files/patch-zxlib.c
@@ -0,0 +1,10 @@
+--- zxlib.c.orig Fri Jul 6 06:46:05 2007
++++ zxlib.c Fri Jul 6 06:46:17 2007
+@@ -15,7 +15,6 @@
+
+ //#include <pthread.h>
+ #ifndef MACOSX
+-#include <malloc.h>
+ #endif
+ #include <memory.h>
+ #include <string.h>
diff --git a/security/zxid/pkg-descr b/security/zxid/pkg-descr
new file mode 100644
index 000000000000..08c71f49e127
--- /dev/null
+++ b/security/zxid/pkg-descr
@@ -0,0 +1,11 @@
+ZXID aims at full stack implementation of all federated identity
+management and identity web services protocols. Initial goal is
+supporting SP role, followed by ID-WSF WSC and IdP roles.
+
+ZXID is light weight, has a small foot print, and is implemented in C.
+It is suitable for both high performance and embedded applications.
+Scripting languages are supported using SWIG, including Perl, PHP and
+Java. The "full stack" nature of ZXID means it's self contained and
+has minimal external library dependencies (see downloads).
+
+WWW: http://zxid.org/
diff --git a/security/zxid/pkg-plist b/security/zxid/pkg-plist
new file mode 100644
index 000000000000..ec8b3e2407c4
--- /dev/null
+++ b/security/zxid/pkg-plist
@@ -0,0 +1,61 @@
+@comment $FreeBSD$
+bin/zxid
+include/zxid/errmac.h
+include/zxid/saml2.h
+include/zxid/wsf.h
+include/zxid/zx-a-data.h
+include/zxid/zx-ac-data.h
+include/zxid/zx-as-data.h
+include/zxid/zx-b-data.h
+include/zxid/zx-b12-data.h
+include/zxid/zx-cb-data.h
+include/zxid/zx-cdm-data.h
+include/zxid/zx-const.h
+include/zxid/zx-dap-data.h
+include/zxid/zx-data.h
+include/zxid/zx-di-data.h
+include/zxid/zx-di12-data.h
+include/zxid/zx-ds-data.h
+include/zxid/zx-dst-data.h
+include/zxid/zx-e-data.h
+include/zxid/zx-ecp-data.h
+include/zxid/zx-ff12-data.h
+include/zxid/zx-gl-data.h
+include/zxid/zx-im-data.h
+include/zxid/zx-is-data.h
+include/zxid/zx-is12-data.h
+include/zxid/zx-lu-data.h
+include/zxid/zx-m20-data.h
+include/zxid/zx-md-data.h
+include/zxid/zx-mm7-data.h
+include/zxid/zx-ns.h
+include/zxid/zx-paos-data.h
+include/zxid/zx-ps-data.h
+include/zxid/zx-sa-data.h
+include/zxid/zx-sa11-data.h
+include/zxid/zx-sbf-data.h
+include/zxid/zx-sec-data.h
+include/zxid/zx-sec12-data.h
+include/zxid/zx-sp-data.h
+include/zxid/zx-sp11-data.h
+include/zxid/zx-subs-data.h
+include/zxid/zx-wsc-data.h
+include/zxid/zx-wsp-data.h
+include/zxid/zx-wsse-data.h
+include/zxid/zx-wst-data.h
+include/zxid/zx-wsu-data.h
+include/zxid/zx-xa-data.h
+include/zxid/zx-xac-data.h
+include/zxid/zx-xasa-data.h
+include/zxid/zx-xasp-data.h
+include/zxid/zx-xenc-data.h
+include/zxid/zx-xml-data.h
+include/zxid/zx-xs-data.h
+include/zxid/zx.h
+include/zxid/zxid.h
+include/zxid/zxidconf.h
+include/zxid/zxidvers.h
+include/zxid/zxwsc.h
+lib/libzxid.a
+lib/libzxid.so.0.0
+@dirrmtry include/zxid