aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-11-26 01:11:52 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-11-26 01:11:52 +0800
commitaaaba009a1984e86a73f958d1ef2e985a3d52e5c (patch)
treea6f5cf28ee5de10b26f310fdfba17544317a8d01 /Mk
parent394b8e7f8791cdac8a6e647585fd938181f6ecfe (diff)
downloadfreebsd-ports-gnome-aaaba009a1984e86a73f958d1ef2e985a3d52e5c.tar.gz
freebsd-ports-gnome-aaaba009a1984e86a73f958d1ef2e985a3d52e5c.tar.zst
freebsd-ports-gnome-aaaba009a1984e86a73f958d1ef2e985a3d52e5c.zip
Update PYMAGICTAG
imp.get_tag() is deprecated since version 3.4. Use sys.implementation.cache_tag directly starting in Python 3.3. Reference: https://docs.python.org/3/library/imp.html#imp.get_tag
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index ff7f14d0e9a0..8a7a9cfce0e2 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -614,7 +614,7 @@ add-plist-pymod:
# When Python version is 3.2+ we rewrite all the filenames
# of TMPPLIST that end with .py[co], so that they conform
# to PEP 3147 (see https://www.python.org/dev/peps/pep-3147/)
-PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
+PYMAGICTAG= ${PYTHON_CMD} -c 'import sys; print(sys.implementation.cache_tag)'
_USES_stage+= 935:add-plist-python
add-plist-python:
@${AWK} '\