aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-02-02 16:33:24 +0800
committerdanfe <danfe@FreeBSD.org>2018-02-02 16:33:24 +0800
commit97acbedd152d94cd445a0ba83a38f1d2c1a76853 (patch)
tree6ea44acade63ad61a8b3f9222c194d73985285d7 /archivers
parentb1330a7aa15fa48089c451cb409bac41c1adadb1 (diff)
downloadfreebsd-ports-gnome-97acbedd152d94cd445a0ba83a38f1d2c1a76853.tar.gz
freebsd-ports-gnome-97acbedd152d94cd445a0ba83a38f1d2c1a76853.tar.zst
freebsd-ports-gnome-97acbedd152d94cd445a0ba83a38f1d2c1a76853.zip
Unbreak the build against Clang 6.0.0 and respect CXXFLAGS.
PR: 225555
Diffstat (limited to 'archivers')
-rw-r--r--archivers/pbzip2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/archivers/pbzip2/Makefile b/archivers/pbzip2/Makefile
index 317c0a4e8e79..4bb4f418980f 100644
--- a/archivers/pbzip2/Makefile
+++ b/archivers/pbzip2/Makefile
@@ -17,8 +17,11 @@ PLIST_FILES= bin/pbzip2 bin/pbunzip2 \
man/man1/pbzip2.1.gz man/man1/pbunzip2.1.gz
post-patch:
+ @${REINPLACE_CMD} -e 's,PRI[iu]MAX, & ,g' ${WRKSRC}/pbzip2.cpp \
+ ${WRKSRC}/BZ2StreamScanner.cpp
# Spell target sources to be understood by both BSD and GNU make(1)
- @${REINPLACE_CMD} -e 's,$$^,$$>&,' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/-O2/s,^,#, ; s,$$^,$$>&,' \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/