aboutsummaryrefslogtreecommitdiffstats
path: root/astro/nova/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-04-16 09:42:47 +0800
committerijliao <ijliao@FreeBSD.org>2004-04-16 09:42:47 +0800
commit173f54b9a943dc8c5b52b90a573bb104f3bf3d6d (patch)
treed9a6c7ce8536a9636d96bf988fa713cedec7431a /astro/nova/Makefile
parentf16cec715f3cc707b41fdec9bdf90a9adb494a9d (diff)
downloadfreebsd-ports-gnome-173f54b9a943dc8c5b52b90a573bb104f3bf3d6d.tar.gz
freebsd-ports-gnome-173f54b9a943dc8c5b52b90a573bb104f3bf3d6d.tar.zst
freebsd-ports-gnome-173f54b9a943dc8c5b52b90a573bb104f3bf3d6d.zip
add nova 0.4
An Integrated Observational Environment for amatuer astronomers
Diffstat (limited to 'astro/nova/Makefile')
-rw-r--r--astro/nova/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/astro/nova/Makefile b/astro/nova/Makefile
new file mode 100644
index 000000000000..28228ab58f52
--- /dev/null
+++ b/astro/nova/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: nova
+# Date created: Apr 16, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= nova
+PORTVERSION= 0.4
+CATEGORIES= astro
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An Integrated Observational Environment for amatuer astronomers
+
+LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
+ gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
+ gnomemm-2.0.1:${PORTSDIR}/x11/libgnomemm \
+ glademm-2.0.1:${PORTSDIR}/devel/libglademm \
+ gconfmm-2.0.1:${PORTSDIR}/devel/gconfmm \
+ gnomecanvasmm-2.0.1:${PORTSDIR}/graphics/libgnomecanvasmm \
+ gnomeuimm-2.0.1:${PORTSDIR}/x11-toolkits/libgnomeuimm \
+ xml\\+\\+-1.0.1:${PORTSDIR}/textproc/libxml++ \
+ nova-0.9.0:${PORTSDIR}/astro/libnova
+RUN_DEPENDS= ${LOCALBASE}/share/nova/catalogs/sky2000.ncd:${PORTSDIR}/astro/sky2000
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/nova/,/share/nova/,' ${WRKSRC}/configure
+
+.include <bsd.port.mk>