aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/nova/Makefile37
-rw-r--r--astro/nova/distinfo2
-rw-r--r--astro/nova/pkg-descr14
-rw-r--r--astro/nova/pkg-plist23
5 files changed, 77 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index bcb8735a4e81..a67b9b631fd5 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -29,6 +29,7 @@
SUBDIR += match
SUBDIR += mymoon
SUBDIR += nightfall
+ SUBDIR += nova
SUBDIR += openuniverse
SUBDIR += p5-Astro-ADS
SUBDIR += p5-Astro-Catalog
diff --git a/astro/nova/Makefile b/astro/nova/Makefile
new file mode 100644
index 000000000000..28228ab58f52
--- /dev/null
+++ b/astro/nova/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: nova
+# Date created: Apr 16, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= nova
+PORTVERSION= 0.4
+CATEGORIES= astro
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An Integrated Observational Environment for amatuer astronomers
+
+LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
+ gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
+ gnomemm-2.0.1:${PORTSDIR}/x11/libgnomemm \
+ glademm-2.0.1:${PORTSDIR}/devel/libglademm \
+ gconfmm-2.0.1:${PORTSDIR}/devel/gconfmm \
+ gnomecanvasmm-2.0.1:${PORTSDIR}/graphics/libgnomecanvasmm \
+ gnomeuimm-2.0.1:${PORTSDIR}/x11-toolkits/libgnomeuimm \
+ xml\\+\\+-1.0.1:${PORTSDIR}/textproc/libxml++ \
+ nova-0.9.0:${PORTSDIR}/astro/libnova
+RUN_DEPENDS= ${LOCALBASE}/share/nova/catalogs/sky2000.ncd:${PORTSDIR}/astro/sky2000
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/nova/,/share/nova/,' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/astro/nova/distinfo b/astro/nova/distinfo
new file mode 100644
index 000000000000..c9923dc1adb1
--- /dev/null
+++ b/astro/nova/distinfo
@@ -0,0 +1,2 @@
+MD5 (nova-0.4.tar.gz) = b7888ab6f6ab3390a85e7673c594a442
+SIZE (nova-0.4.tar.gz) = 367120
diff --git a/astro/nova/pkg-descr b/astro/nova/pkg-descr
new file mode 100644
index 000000000000..bca21a631364
--- /dev/null
+++ b/astro/nova/pkg-descr
@@ -0,0 +1,14 @@
+The Nova project is a free Integrated Observational Environment for amatuer
+astronomers. It combines Ephemeris, Sky view, Observatory control and basic
+Image manipulation functionality into a single application.
+
+Features
+ * Virtual view of night sky
+ * Ephemeris calculation and plotting.
+ * Telescope control
+ * CCD control
+ * Image manipulation
+ * Supports most ASCII astronomical object catalogs
+ * Automatic scheduling of observational activity.
+
+WWW: http://nova.sourceforge.net/
diff --git a/astro/nova/pkg-plist b/astro/nova/pkg-plist
new file mode 100644
index 000000000000..f81c390eb774
--- /dev/null
+++ b/astro/nova/pkg-plist
@@ -0,0 +1,23 @@
+bin/nova
+bin/catbuilder
+%%DATADIR%%/pixmaps/asteroid-small.xpm
+%%DATADIR%%/pixmaps/comet-small.xpm
+%%DATADIR%%/pixmaps/earth-small.xpm
+%%DATADIR%%/pixmaps/galaxy-small.xpm
+%%DATADIR%%/pixmaps/jupiter-small.xpm
+%%DATADIR%%/pixmaps/mars-small.xpm
+%%DATADIR%%/pixmaps/mercury-small.xpm
+%%DATADIR%%/pixmaps/moon-small.xpm
+%%DATADIR%%/pixmaps/nebula-small.xpm
+%%DATADIR%%/pixmaps/neptune-small.xpm
+%%DATADIR%%/pixmaps/other-small.xpm
+%%DATADIR%%/pixmaps/pluto-small.xpm
+%%DATADIR%%/pixmaps/saturn-small.xpm
+%%DATADIR%%/pixmaps/star6.xpm
+%%DATADIR%%/pixmaps/star8.xpm
+%%DATADIR%%/pixmaps/sun-small.xpm
+%%DATADIR%%/pixmaps/uranus-small.xpm
+%%DATADIR%%/pixmaps/venus-small.xpm
+%%DATADIR%%/pixmaps/nova_logo.png
+@dirrm %%DATADIR%%/pixmaps
+@unexec rmdir %D/%%DATADIR%% 2>/dev/null || true
apanese?id=5c2c2a073bd6cdc6c759eafa3bade4aa4bc19aeb'>Update to 20141224vanilla2014-12-262-4/+4 * Bump portrevision after png updatebapt2014-12-261-1/+1 * Remove imlib1bapt2014-12-261-0/+1 * Change libpng15.so to libpng.so in LIB_DEPENDS to prepare the upgradeantoine2014-12-261-1/+1 * Remove abandonware blocking decomissioning imlibbapt2014-12-2512-220/+0 * Remove abandonware blocking decomissioning imlibbapt2014-12-2515-257/+0 * - Update to 4.1sunpoet2014-12-242-3/+3 * Update to 20141220.nobutaka2014-12-236-30/+63 * Get rid of gnomehierbapt2014-12-211-2/+2 * Cleanup plistbapt2014-12-2111-19/+0 * Update to 4.3.5.jkim2014-12-191-4/+4 * japanese/ebnetd add user and group for daemon processespawel2014-12-163-3/+31 * - Update from 0.20141105 to 0.20141201danilo2014-12-092-4/+3 * Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla intijl2014-12-0915-21/+22 * Remove invalid line from plistantoine2014-12-071-1/+0 * Update "BSD" licensefeld2014-12-071-1/+1 * - Remove local MASTER_SITE which is going to disappearamdmi32014-12-061-3/+2 * Add a patch from SA bug #7107, to quiet warnings due to bad usage of $^Vadamw2014-12-011-1/+1 * Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. Thetijl2014-11-305-23/+13 * - Update to 4.1.4tota2014-11-292-3/+3 * Update to 4.3.4.jkim2014-11-271-4/+4 * Change the way Perl modules are installed, update the default Perl to 5.18.mat2014-11-2654-115/+106 * - While I'm here, update to 4.0.1sunpoet2014-11-252-6/+4 * Remove code unused with stagingantoine2014-11-2317-52/+0 * Add japanese/font-ipamjm, Japanese TrueType fonts distributed byhrs2014-11-238-0/+202 * Update to 2.0.0-DEV.hrs2014-11-224-13/+22 * Mark BROKEN: Fails to buildantoine2014-11-201-0/+2 * The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.kwm2014-11-192-1/+48 * - Update from 0.20141001 to 0.20141105danilo2014-11-192-3/+3 * Cleanup plistantoine2014-11-12161-885/+52 * - Fix shebangsantoine2014-11-124-9/+4 * japanese/mh: fixesrobak2014-11-112-1/+19 * japanese/nethack34: Fix segfault on amd64 among other thingsmarino2014-11-106-12/+93 * japanese/py-mecab: some fixespi2014-11-081-1/+5 * japanese/p5-MeCab: some fixespi2014-11-082-5/+5 * - Remove a few remaining $Id$ from pkg-plistsak2014-11-0710-10/+0 * - Chase GNU Emacs updatesashish2014-11-056-5/+6 * - Update to 20141031.kuriyama2014-11-044-10/+10 * Simplify plistbapt2014-11-011-29/+1 * Simplify plistbapt2014-11-012-7/+3 * Simplify plistbapt2014-11-011-6/+1 * Update to 4.3.3.jkim2014-11-011-4/+4 * Mark broken with Perl 5.18 and newerswills2014-10-271-0/+4 * Remove @dirrm and @dirrmtry entries from the Qt ports.rakuco2014-10-241-2/+0 * japanese/mh: multiple fixesrobak2014-10-204-11/+51 * - Convert ports from german/, java/, japanese/ and ports-mgmt/ to newmva2014-10-2010-20/+16 * KDE/FreeBSD team presents KDE SC 4.14.2 and KDE Workspace 4.11.13!makc2014-10-196-31/+118 * japanese/ebnetd: Remove @dirrm, use @sample, use @dir()marino2014-10-182-4/+7 * - Fix ${arch}_BROKEN statements to correct BROKEN_${arch}amdmi32014-10-174-12/+4 * Update to 4.3.2.jkim2014-10-172-5/+4 * japanese/mecab: Remove @dirrm and use @samplemarino2014-10-162-7/+4 * - Fix segmentation fault with recent Ruby-GNOME2.ume2014-10-152-24/+16 * Close out a bunch of PRs that only remove @dirrmmarino2014-10-152-125/+0 * Add missing dependencies and CPE data.des2014-10-151-1/+8 * - update to version 4.4.6ohauer2014-10-153-45/+3 * japanese/mecab: Fix typomarino2014-10-121-1/+1 * Fix build on 10.0.hrs2014-10-071-11/+4 * - Fix build failure on braches with Clang older than 3.4.hrs2014-10-074-23/+103 * Remove redundant patches mistakenly added back in r367909.hrs2014-10-0610-115026/+2 * - Update from 0.20140901 to 0.20141001danilo2014-10-042-3/+3 * - Update to 2.6.0sunpoet2014-10-041-0/+1 * japanese/slrn is not jobs safemarino2014-10-011-0/+2 * - Set PORTSCOUT to limit version 3.0.Xtota2014-10-011-0/+2 * - Update to 3.0.8tota2014-09-282-3/+4 * - Repocopy japanese/rubygem-jpmobile to japanese/rubygem-jpmobile4tota2014-09-284-0/+53 * Allow staging as a regular userantoine2014-09-281-7/+2 * - Set CPPFLAGS and LIBS in a number of ports so configure can find libintl.htijl2014-09-251-4/+4 * - Convert to USES=autoreconftijl2014-09-251-21/+14 * - Remove USE_AUTOTOOLStijl2014-09-251-12/+11 * Do not violate stagedir (and allow staging as a regular user)antoine2014-09-251-1/+1 * Update to version 20140904pawel2014-09-212-4/+4 * Update to version 201409pawel2014-09-212-7/+7 * Add new port japanese/latex-jlistingmarino2014-09-204-0/+39 * Remove expired portsrene2014-09-2016-341/+0 * fix build with perl 5.18az2014-09-202-1/+11 * graphics/imlib:tijl2014-09-203-3/+3 * Convert to USES=autoreconftijl2014-09-191-6/+3 * Allow staging as a regular userantoine2014-09-151-1/+1 * Use default LIBTOOLIZE_ARGStijl2014-09-141-1/+0 * devel/glib12 x11-toolkits/gtk12:tijl2014-09-134-4/+4 * The BROKEN message (Does not compile with GCC 4.2) isn't accurate. It simplyadamw2014-09-131-8/+2 * - Drop .la files for japanese/kakasi, no dependees require themamdmi32014-09-123-4/+5 * - Fix a bug which prevented a bind(2) call from working.hrs2014-09-1149-90/+115895 * Update the default version of GCC in the Ports Collection from GCC 4.7.4gerald2014-09-1111-7/+11 * Remove four unrelated staged portsmarino2014-09-107-151/+0 * Using USES=uidfix together with PLIST_SUB=WWWUID=${WWWOWN} WWWGID=${WWWGRP}antoine2014-09-091-1/+1 * Stage japanese/ng-develmarino2014-09-093-36/+34 * - Update to 2.13.4.11culot2014-09-083-6/+6 * Allow staging as a regular userantoine2014-09-071-4/+3 * Allow staging as a regular userantoine2014-09-071-0/+1 * Allow staging as a regular userantoine2014-09-071-4/+3 * Remove unstaged japanese/prime and 3 of its dependencies (2 unstaged)marino2014-09-0723-366/+0 * Remove unstaged tcl/tk 8.0 and two affected staged portsmarino2014-09-0727-1983/+0 * Stage and revamp japanese/k12, assign maintainership to submittermarino2014-09-076-97/+54 * Stage japanese/nethack34 and unbreakmarino2014-09-0712-192/+623 * Change MAINTAINER to bz-ports@ as discussed with bugzilla@ (now bz-ports@)flo2014-09-061-1/+1 * Fix mozc-server and mozc-client builds by directly depending onadamw2014-09-041-1/+2 * - Update from 0.20140804 to 0.20140901danilo2014-09-042-3/+3 * Support STAGEDIR.vanilla2014-09-036-34/+49 * - Update to 20140829.kuriyama2014-09-034-10/+10 * Connect ng-canna to the buildbapt2014-09-021-0/+1 * Resurrect ng-canna and stage itbapt2014-09-024-33/+52 * Add USES=libtool to accessibility/atkmm and bump dependent portstijl2014-09-021-1/+1 * Remove non staged ports without pending PR from j*bapt2014-09-0261-4427/+0 * Use USES=python instead of USE_PYTHON_*.hrs2014-09-011-4/+2 * Fix build on branches with GCC 4.2.1.hrs2014-09-011-1/+3 * Fix MASTER_SITES.hrs2014-09-011-1/+1 * textproc/scim:tijl2014-08-319-9/+9 * - update to 4.4.5ohauer2014-08-312-3/+3 * Update Mozc to 1.15.1868.102.hrs2014-08-3117-488/+232 * dns/libidn:tijl2014-08-311-1/+1 * Remove ports related to Adobe Reader.hrs2014-08-305-30/+0 * Stage japanese/waeijiro-fpwmarino2014-08-302-32/+31 * japanese/eijiro-fpw: Small fix to cover compressed casemarino2014-08-301-5/+7 * Fix filename conflict with dvi2tty installed by TeXLive.hrs2014-08-301-10/+5 * japanese/eijire-fpw: Thanks freshports sanitymarino2014-08-301-1/+1 * Stage japanese/eijiro-fpwmarino2014-08-303-44/+41 * - Fix build with newer versions of makeinfo.hrs2014-08-308-14/+97 * - Fix build. A "grep" directory conflicted with "grep" target.hrs2014-08-302-9/+10 * Stage japanese/xyakumarino2014-08-282-7/+9 * japanese/edict-utf-8: Update WWWmarino2014-08-281-1/+1 * Stage japanese/manmarino2014-08-2711-85/+239 * - Fix missing library problems when the linker enforces explicit linkingtijl2014-08-261-1/+9 * Reset maintainership for non staged portsbapt2014-08-252-2/+2 * Stagify.vanilla2014-08-251-13/+8 * Stagify.vanilla2014-08-252-16/+30 * Stage japanese/alias-fonts and assign maintainership to submittermarino2014-08-254-14/+8 * * Add staging support.hrs2014-08-242-33/+112 * Mark BROKEN: Fails to buildantoine2014-08-241-0/+2 * japanese/ruby-mecab: fix LICENSE, strip shared libraryswills2014-08-231-1/+3 * Update TeXLive to 2014.hrs2014-08-225-3569/+4069 * Canonicalize a few LICENSE_PERMSantoine2014-08-221-1/+1 * Berkeley DB cleanup, remove versions 4.0 ... 4.7.mandree2014-08-221-1/+1 * Update to 0.0.464.hrs2014-08-212-3/+3 * Stage japanese/xdtpmarino2014-08-212-79/+93 * Stage japanese/ne, unbreak on FreeBSD 10+, unbreak on amd64marino2014-08-213-30/+59 * Stage japanese/ddskkmarino2014-08-212-26/+37 * many ruby/rubygem ports: death of rubyforge.orgswills2014-08-191-0/+3 * Convert most NO_INSTALL_MANPAGES to USES=imake:nomanantoine2014-08-192-4/+2 * - Remove deprecated INSTALLS_EGGINFO knob. Since the ports use distutils,mva2014-08-171-1/+0 * Upgrade OpenEXR and ilmbase to 2.2.0.mandree2014-08-163-1/+3 * - Switch to USES=libtool, drop .la filesamdmi32014-08-162-5/+5 * - Drop .la files for print/tex-ptexencamdmi32014-08-151-1/+1 * Stagify.vanilla2014-08-151-9/+5 * skkinput3 is not jobs safeantoine2014-08-121-0/+1 * Finish stage supportantoine2014-08-102-2/+1 * - Replace libtool BUILD_DEPENDS with USE_AUTOTOOLS=libtoolizetijl2014-08-101-11/+8 * Convert the Python framework bits to USES=python.mva2014-08-091-3/+2 * japanese/rogue_s: support stagewg2014-08-081-24/+12 * japanese/leafrogue: fix installationwg2014-08-082-5/+5 * - Update from 0.20140602 to 0.20140804danilo2014-08-072-3/+3 * Bump PORTREVISION on more ports that depend on libgcrypt after the updatetijl2014-08-061-1/+1 * In some straightforward cases, protect documentation behindadamw2014-08-0413-324/+19 * japanese/kdrill: Update version 6.4 => 6.5 and stagemarino2014-07-313-34/+26 * Unbreakantoine2014-07-301-1/+1 * security/libgcrypt: 1.5.3_3 -> 1.6.1pi2014-07-301-1/+1 * remove NO_STAGE.vanilla2014-07-301-1/+0 * - Switch databases/namazu2 to USES=libtool, drop .la filesamdmi32014-07-301-0/+1 * Convert some more USE_BZIP2 to USES=tar:bzip2adamw2014-07-308-8/+8 * Remove the final usages of USE_XZ from the tree, and replace them withadamw2014-07-301-1/+1 * Convert a bunch of EXTRACT_SUFX=... into USES=tar:...adamw2014-07-306-12/+6 * Convert a bunch of USE_BZIP2 to USES=tar:bzip2adamw2014-07-302-4/+2 * Rename all patches that contain '::' as a path separator, and useadamw2014-07-305-0/+0 * Rename the rather surprising number of japanese/ patch-xy patchesadamw2014-07-2969-8/+6 * Stage japanese/marumoji-fontsmarino2014-07-275-44/+65 * - Switch to USES=libtool, drop .la filesamdmi32014-07-252-1/+4 * - Convert texproc/uim and friends to USES=libtool, drop .la filesamdmi32014-07-253-6/+2 * - Switch to USES=libtool, drop .la filesamdmi32014-07-242-7/+6 * Reset maintainership for ports not staged with no pending PRbapt2014-07-246-6/+6 * Finish some removalsantoine2014-07-231-1/+0 * Remove japanese/teTeXbapt2014-07-234-41/+0 * Remove japanese/ptex forgotten in previous commitsbapt2014-07-2317-929/+0 * Remove some teTeX bitsbapt2014-07-2321-1235/+0 * Decomission a couple of japanese teTeX portsbapt2014-07-2324-1267/+0 * Replace japaneses/xdvik with texlive version directlybapt2014-07-2314-758/+0 * Switch to use texlive version of ptexbapt2014-07-231-2/+2 * - Replace security/gnutls with security/gnutls3 and update to 3.2.15tijl2014-07-231-0/+1 * Fix LIB_DEPENDSantoine2014-07-211-2/+2 * Fix some non default LIB_DEPENDSbapt2014-07-161-1/+1 * Add DOCS option where PORTDOCS appears in plist.adamw2014-07-168-0/+16 * Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.adamw2014-07-153-1/+5 * Stagify.vanilla2014-07-151-3/+2 * remove NO_STAGE.vanilla2014-07-151-1/+0 * Stagify.vanilla2014-07-152-10/+7 * 1: Stagify.vanilla2014-07-152-4/+3 * remove NO_STAGE.vanilla2014-07-151-1/+0 * Modernize LIB_DEPENDSbapt2014-07-151-1/+1 * Modernize LIB_DEPENDSbapt2014-07-1415-21/+21 * - Update to 158nivit2014-07-124-175/+48 * 1: remove NO_STAGE.vanilla2014-07-101-5/+3 * Mark 5 unstaged and unmaintained ports as jobs unsafe (taken from dports)marino2014-07-071-0/+3 * Add a patch to fix the DBM bayes store, which failed due to a taintedadamw2014-07-061-1/+1 * japanese/slrn: stage supportmarino2014-07-062-4/+4 * japanese/scim-tables: stage and define scim as BUILD_DEPENDS (dports)marino2014-07-061-11/+3 * Remove indefinite articles and trailing periods from COMMENT, plus minorolgeni2014-07-0628-28/+28 * - Support STAGEDIRtota2014-07-068-95/+121 * - Update to 20140630.kuriyama2014-07-054-10/+10 * Support stage for texlive, given it is impossible to rebuild the fmt files intobapt2014-07-051-4/+3 * Unbreakantoine2014-07-041-2/+2 * Remove NOPORTDOCS and NOPORTEXAMPLES.adamw2014-07-043-5/+9 * - Remove indefinite article from COMMENTamdmi32014-07-041-8/+3 * - Add stage supportdanilo2014-07-032-12/+9 * Resetting maintainership on ports that have not been staged and without anyantoine2014-07-0326-26/+26 * - Switch to USES=libtool, drop .la filesamdmi32014-07-02