aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2018-04-03 04:19:06 +0800
committeradridg <adridg@FreeBSD.org>2018-04-03 04:19:06 +0800
commit8673eacf2b4e75c72696e3ce775cac1eb022686a (patch)
treef1cbba53ae020b845a553f06fa52c4624aa947f8 /astro
parent78e089b632c0e5a6ffb8cdae517cfa4b11980732 (diff)
downloadfreebsd-ports-gnome-8673eacf2b4e75c72696e3ce775cac1eb022686a.tar.gz
freebsd-ports-gnome-8673eacf2b4e75c72696e3ce775cac1eb022686a.tar.zst
freebsd-ports-gnome-8673eacf2b4e75c72696e3ce775cac1eb022686a.zip
Fix astro/qmapshack ahead of CMake 3.11.
Because of the way CMake 3.11 orders includes in mocs_compilation.cpp, it shows up cases where headers don't have all of the necessary includes or forward-type-declarations in place. Add one here to fix the build. The error message is in the patch. Also reported upstream, https://bitbucket.org/maproom/qmapshack/issues/325/cmake-311-build-fix but it had already been (unrelatedly) fixed upstream in https://bitbucket.org/maproom/qmapshack/commits/2968b238 Approved by: tcberner (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D14932
Diffstat (limited to 'astro')
-rw-r--r--astro/qmapshack/Makefile1
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h13
2 files changed, 14 insertions, 0 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 23a18c5c9d39..6fe565cc2f97 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qmapshack
PORTVERSION= 1.11.0
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
diff --git a/astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h b/astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h
new file mode 100644
index 000000000000..679385fd0bc7
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h
@@ -0,0 +1,13 @@
+Provide full definition of IDrawContext, needed when #including
+this file in a context (ha!) without that definition already.
+
+--- src/qmapshack/dem/IDem.h.orig 2018-02-23 16:39:15 UTC
++++ src/qmapshack/dem/IDem.h
+@@ -19,6 +19,7 @@
+ #ifndef IDEM_H
+ #define IDEM_H
+
++#include "canvas/IDrawContext.h"
+ #include "canvas/IDrawObject.h"
+ #include <QObject>
+ #include <QPointer>