aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hamfax
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /comms/hamfax
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'comms/hamfax')
-rw-r--r--comms/hamfax/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/comms/hamfax/Makefile b/comms/hamfax/Makefile
index 7c7589f4db65..3db5a1afb95e 100644
--- a/comms/hamfax/Makefile
+++ b/comms/hamfax/Makefile
@@ -12,10 +12,10 @@ COMMENT= QT application for sending and receiving facsimiles over radio
LIB_DEPENDS= libaudiofile.so:audio/libaudiofile
-USE_QT4= gui moc_build
+USE_QT= gui moc_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-USES= gmake pkgconfig tar:bzip2
+USES= gmake pkgconfig qt:4 tar:bzip2
.include <bsd.port.mk>