aboutsummaryrefslogtreecommitdiffstats
path: root/comms/ruby-termios/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-10-08 19:16:04 +0800
committerknu <knu@FreeBSD.org>2002-10-08 19:16:04 +0800
commite2ec724e949f67699715ff611cb79752d2b3c1ce (patch)
tree7ba7a9a8bd9e2e05164532770a152ed81bdc1019 /comms/ruby-termios/Makefile
parent51685ad2c912ee5293d84b780d123f095204b973 (diff)
downloadfreebsd-ports-gnome-e2ec724e949f67699715ff611cb79752d2b3c1ce.tar.gz
freebsd-ports-gnome-e2ec724e949f67699715ff611cb79752d2b3c1ce.tar.zst
freebsd-ports-gnome-e2ec724e949f67699715ff611cb79752d2b3c1ce.zip
Update to 0.9.1. (PORTEPOCH bumped)
Diffstat (limited to 'comms/ruby-termios/Makefile')
-rw-r--r--comms/ruby-termios/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/comms/ruby-termios/Makefile b/comms/ruby-termios/Makefile
index eb828ac93039..7f100e500577 100644
--- a/comms/ruby-termios/Makefile
+++ b/comms/ruby-termios/Makefile
@@ -6,30 +6,41 @@
#
PORTNAME= termios
-PORTVERSION= 20001115
-PORTREVISION= 1
+PORTVERSION= 0.9.1
+PORTEPOCH= 1
CATEGORIES= comms ruby
-MASTER_SITES= http://arika.org/pub/Tools/Ruby/
+MASTER_SITES= http://arika.org/archive/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
+DOCS= ChangeLog README termios.html termios.rd
+
post-patch:
- ${RUBY} -i -pe 'gsub /ttyS\d/, "cuaa0"' ${WRKSRC}/test/*.rb
+ ${RUBY} -i -pe 'gsub(/ttyS\d/, "cuaa0")' ${WRKSRC}/examples/*.rb
+ ${RUBY} -i -pe 'gsub(/\.c_/, ".")' ${WRKSRC}/examples/*.rb
+
+post-build:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}; ${RUBY_RD2} termios.rd > termios.html
+.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${CP} -R ${WRKSRC}/test/*.rb ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.rb ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_MODDOCDIR}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
.endif
.include <bsd.port.mk>