aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-24 04:46:26 +0800
committeryuri <yuri@FreeBSD.org>2018-03-24 04:46:26 +0800
commit0a051dc793064b0c99680f516b6ec4d95e09778a (patch)
tree8d974d83db22a92afcecfe41bfc54d9cdf1b4292 /comms
parent743276fcd0da1aaa513db68a77b37876b710296c (diff)
downloadfreebsd-ports-gnome-0a051dc793064b0c99680f516b6ec4d95e09778a.tar.gz
freebsd-ports-gnome-0a051dc793064b0c99680f516b6ec4d95e09778a.tar.zst
freebsd-ports-gnome-0a051dc793064b0c99680f516b6ec4d95e09778a.zip
comms/aldo: Update 0.7.5 -> 0.7.7
Port changes: * Change to DISTVERSION * Add LICENSE/LICENSE_FILE * Remove USE_GCC * Add USES=localbase instead of CPPFLAGS/LIBS PR: 226349 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: lambert@lambertfam.org (maintainer timeout; 19 days)
Diffstat (limited to 'comms')
-rw-r--r--comms/aldo/Makefile11
-rw-r--r--comms/aldo/distinfo5
-rw-r--r--comms/aldo/files/patch-configure4
-rw-r--r--comms/aldo/files/patch-include_Makefile.in4
-rw-r--r--comms/aldo/files/patch-src_audioworkspace.cc20
-rw-r--r--comms/aldo/files/patch-src_menu.cc25
6 files changed, 37 insertions, 32 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index ce1a614ee430..e788b4be5b3c 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= aldo
-PORTVERSION= 0.7.5
-PORTREVISION= 6
+DISTVERSION= 0.7.7
CATEGORIES= comms hamradio
MASTER_SITES= SAVANNAH
MAINTAINER= lambert@lambertfam.org
COMMENT= Morse code training program
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libao.so:audio/libao
+USES= compiler:c++0x gmake localbase tar:bzip2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-USES= gmake libtool tar:bzip2
-USE_GCC= any
PLIST_FILES= bin/aldo \
man/man1/aldo.1.gz
diff --git a/comms/aldo/distinfo b/comms/aldo/distinfo
index e474475e8103..c3513c6750b3 100644
--- a/comms/aldo/distinfo
+++ b/comms/aldo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (aldo-0.7.5.tar.bz2) = 15f9dbcab48c6ba3fba6a4d3e9a030bad3255d4a4b47677388a1e46782aa84ea
-SIZE (aldo-0.7.5.tar.bz2) = 98612
+TIMESTAMP = 1521837318
+SHA256 (aldo-0.7.7.tar.bz2) = f1b8849d09267fff3c1f5122097d90fec261291f51b1e075f37fad8f1b7d9f92
+SIZE (aldo-0.7.7.tar.bz2) = 112000
diff --git a/comms/aldo/files/patch-configure b/comms/aldo/files/patch-configure
index f67b730eae30..ecac41752b54 100644
--- a/comms/aldo/files/patch-configure
+++ b/comms/aldo/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2007-11-05 09:22:11 UTC
+--- configure.orig 2012-03-31 11:55:36 UTC
+++ configure
-@@ -2220,9 +2220,6 @@ am__tar='${AMTAR} chof - "$$tardir"'; am
+@@ -2725,9 +2725,6 @@ am__tar='$${TAR-tar} chof - "$$tardir"'
diff --git a/comms/aldo/files/patch-include_Makefile.in b/comms/aldo/files/patch-include_Makefile.in
index 2a57933fe40e..370528edcfa7 100644
--- a/comms/aldo/files/patch-include_Makefile.in
+++ b/comms/aldo/files/patch-include_Makefile.in
@@ -1,6 +1,6 @@
---- include/Makefile.in.orig 2017-03-24 13:33:28 UTC
+--- include/Makefile.in.orig 2012-03-31 11:55:36 UTC
+++ include/Makefile.in
-@@ -101,7 +101,7 @@ PATH_SEPARATOR = @PATH_SEPARATOR@
+@@ -105,7 +105,7 @@ PATH_SEPARATOR = @PATH_SEPARATOR@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
diff --git a/comms/aldo/files/patch-src_audioworkspace.cc b/comms/aldo/files/patch-src_audioworkspace.cc
deleted file mode 100644
index 6f0b4288e755..000000000000
--- a/comms/aldo/files/patch-src_audioworkspace.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/audioworkspace.cc.orig 2007-11-05 08:58:46 UTC
-+++ src/audioworkspace.cc
-@@ -31,7 +31,8 @@
- #include <cmath>
- #include <iostream>
- #include <limits>
--
-+#include <string.h>
-+
- using namespace std;
- using namespace libaudiostream;
-
-@@ -104,6 +105,7 @@ oastream AudioWorkSpace::create_output_s
- {
- ao_sample_format format;
-
-+ memset(&format, 0, sizeof(format));
- format.bits = m_bits;
- format.channels = m_channels;
- format.rate = m_sample_rate;
diff --git a/comms/aldo/files/patch-src_menu.cc b/comms/aldo/files/patch-src_menu.cc
new file mode 100644
index 000000000000..0431124a33d4
--- /dev/null
+++ b/comms/aldo/files/patch-src_menu.cc
@@ -0,0 +1,25 @@
+--- src/menu.cc.orig 2012-03-31 11:32:34 UTC
++++ src/menu.cc
+@@ -112,19 +112,19 @@ void Menu::add_item(id_type id, std::str
+
+ void Menu::add_item_at(unsigned int pos, id_type id, std::string c, Function1 f)
+ {
+- IT it(&m_its[pos]);
++ IT it(m_its.begin() + pos);
+ m_its.insert(it, Item(id,c,f) );
+ }
+
+ void Menu::add_item_at(unsigned int pos, id_type id, std::string c, Function2 f)
+ {
+- IT it(&m_its[pos]);
++ IT it(m_its.begin() + pos);
+ m_its.insert(it, Item(id,c,f) );
+ }
+
+ void Menu::delete_item_at(unsigned int pos)
+ {
+- IT it(&m_its[pos]);
++ IT it(m_its.begin() + pos);
+ m_its.erase(it);
+ }
+