aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-08-26 00:03:32 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-08-26 00:03:32 +0800
commit7fa29625036e5a038b05d290f30ccba3cf65b203 (patch)
treec8a818ad147d766c646ee1689cf0f379ca5b9094 /databases
parent45cec2d53a892853a47868b05edf0c06caa6d928 (diff)
downloadfreebsd-ports-gnome-7fa29625036e5a038b05d290f30ccba3cf65b203.tar.gz
freebsd-ports-gnome-7fa29625036e5a038b05d290f30ccba3cf65b203.tar.zst
freebsd-ports-gnome-7fa29625036e5a038b05d290f30ccba3cf65b203.zip
- Use -pthread instead of deprecated PTHREAD_LIBS
- Use !${PORT_OPTIONS:Mfoo} instead of empty(PORT_OPTIONS:Mfoo)
Diffstat (limited to 'databases')
-rw-r--r--databases/leveldb/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/leveldb/Makefile b/databases/leveldb/Makefile
index e6e8f357a83c..4c2f12522a63 100644
--- a/databases/leveldb/Makefile
+++ b/databases/leveldb/Makefile
@@ -39,11 +39,11 @@ SNAPPY= 0
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/build_detect_platform
-.if empty(PORT_OPTIONS:MGPERFTOOLS)
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|' ${WRKSRC}/build_detect_platform
+.if !${PORT_OPTIONS:MGPERFTOOLS}
@${REINPLACE_CMD} -e 's| -ltcmalloc||' ${WRKSRC}/build_detect_platform
.endif
-.if empty(PORT_OPTIONS:MSNAPPY)
+.if !${PORT_OPTIONS:MSNAPPY}
@${REINPLACE_CMD} -e 's| -DSNAPPY||; s| -lsnappy||' ${WRKSRC}/build_detect_platform
.endif