aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/leveldb/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/databases/leveldb/Makefile b/databases/leveldb/Makefile
index e6e8f357a83c..4c2f12522a63 100644
--- a/databases/leveldb/Makefile
+++ b/databases/leveldb/Makefile
@@ -39,11 +39,11 @@ SNAPPY= 0
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/build_detect_platform
-.if empty(PORT_OPTIONS:MGPERFTOOLS)
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|' ${WRKSRC}/build_detect_platform
+.if !${PORT_OPTIONS:MGPERFTOOLS}
@${REINPLACE_CMD} -e 's| -ltcmalloc||' ${WRKSRC}/build_detect_platform
.endif
-.if empty(PORT_OPTIONS:MSNAPPY)
+.if !${PORT_OPTIONS:MSNAPPY}
@${REINPLACE_CMD} -e 's| -DSNAPPY||; s| -lsnappy||' ${WRKSRC}/build_detect_platform
.endif