aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2017-08-22 04:06:35 +0800
committerosa <osa@FreeBSD.org>2017-08-22 04:06:35 +0800
commitccf28a195bb939debf5edadecc44eebe12e2adcc (patch)
tree52e14ccfc464deecbb3d6b6411202c775969272a /databases
parent485a4357e442b1623dc13465eb03503b25d861a7 (diff)
downloadfreebsd-ports-gnome-ccf28a195bb939debf5edadecc44eebe12e2adcc.tar.gz
freebsd-ports-gnome-ccf28a195bb939debf5edadecc44eebe12e2adcc.tar.zst
freebsd-ports-gnome-ccf28a195bb939debf5edadecc44eebe12e2adcc.zip
Attempt to fix the issue for 10.x, 11.x and head on i386.
networking.o: In function `createClient': networking.c:(.text+0x189): undefined reference to `__atomic_fetch_add_8' cc: error: linker command failed with exit code 1 (use -v to see invocation) Do not bump PORTREVISION since this change affects i386 only what's broken till now.
Diffstat (limited to 'databases')
-rw-r--r--databases/redis-devel/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 9c1a98cf0d31..104bdcf06bf8 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -12,8 +12,6 @@ COMMENT= Persistent key-value database with built-in net interface
LICENSE= BSD3CLAUSE
-BROKEN_FreeBSD_10_i386= undefined reference to __atomic_fetch_add_8
-
USES= execinfo
OPTIONS_DEFINE= TESTS TRIB
@@ -27,6 +25,11 @@ TRIB_DESC= Install redis-trib.rb (lang/ruby req.)
.include <bsd.port.options.mk>
+.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
+# Needed for __atomic_fetch_add_8
+CFLAGS+= -march=i586
+.endif
+
.if ${PORT_OPTIONS:MTRIB}
CATEGORIES+= ruby
USE_RUBY= yes