aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-10-01 03:24:30 +0800
committertijl <tijl@FreeBSD.org>2016-10-01 03:24:30 +0800
commitf493fce6a3261de0136fe170a7b704c4fe236b88 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /databases
parent70cc79c60e2f5a9e208b1727c67b6fe406e80c61 (diff)
downloadfreebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.tar.gz
freebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.tar.zst
freebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.zip
Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'databases')
-rw-r--r--databases/firebird25-server/Makefile3
-rw-r--r--databases/rocksdb/Makefile2
2 files changed, 2 insertions, 3 deletions
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index d5ec0ffc7c5e..e712ad3c0584 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -90,8 +90,7 @@ UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
PKGINSTALL?= ${PKGDIR}/pkg-install-server
.else
# Client part stuff
-USES+= libedit
-LDFLAGS+= -L${LOCALBASE}/lib # to link in lncurses pulled in by libedit
+USES+= libedit
CONFIGURE_ARGS+= --with-system-editline
CONFIGURE_ENV+= ac_cv_lib_edit_readline="yes"
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index ebf06475aaa1..7e3f17ae1fe8 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -24,7 +24,7 @@ CPPFLAGS+= -DOS_FREEBSD
MAKE_ENV= CXX=${CXX}
USE_CXXSTD= c++11
USE_LDCONFIG= yes
-USES= compiler:c++11-lib gmake localbase
+USES= compiler:c++11-lib gmake localbase:ldflags
PORTDATA= make_config.mk