aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/firebird25-server/Makefile3
-rw-r--r--databases/rocksdb/Makefile2
2 files changed, 2 insertions, 3 deletions
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index d5ec0ffc7c5e..e712ad3c0584 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -90,8 +90,7 @@ UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
PKGINSTALL?= ${PKGDIR}/pkg-install-server
.else
# Client part stuff
-USES+= libedit
-LDFLAGS+= -L${LOCALBASE}/lib # to link in lncurses pulled in by libedit
+USES+= libedit
CONFIGURE_ARGS+= --with-system-editline
CONFIGURE_ENV+= ac_cv_lib_edit_readline="yes"
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index ebf06475aaa1..7e3f17ae1fe8 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -24,7 +24,7 @@ CPPFLAGS+= -DOS_FREEBSD
MAKE_ENV= CXX=${CXX}
USE_CXXSTD= c++11
USE_LDCONFIG= yes
-USES= compiler:c++11-lib gmake localbase
+USES= compiler:c++11-lib gmake localbase:ldflags
PORTDATA= make_config.mk