aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-12-27 14:43:52 +0800
committerkoobs <koobs@FreeBSD.org>2015-12-27 14:43:52 +0800
commit97502ee478ba29b58bcccff0b96272ed4afd15f7 (patch)
tree7382d6b03be782573e97f6cec886e2dcbc03a69e /devel
parentd3cb7807faf99a511ce7258275de47a4cf0de74c (diff)
downloadfreebsd-ports-gnome-97502ee478ba29b58bcccff0b96272ed4afd15f7.tar.gz
freebsd-ports-gnome-97502ee478ba29b58bcccff0b96272ed4afd15f7.tar.zst
freebsd-ports-gnome-97502ee478ba29b58bcccff0b96272ed4afd15f7.zip
[NEW] devl/py-pycmd: Tools for managing/searching Python related files
pycmd is a collection of command line tools for helping with Python development: * py.cleanup: remove .pyc and similar files * py.lookup: find text in recursively found .py files * py.countloc: give LOCs for lines and testlines * py.which: print location of an importable package or module WWW: https://pypi.python.org/pypi/pycmd
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pycmd/Makefile24
-rw-r--r--devel/py-pycmd/distinfo2
-rw-r--r--devel/py-pycmd/pkg-descr9
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2becaf88cef9..e5fdc3dc3f8f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4209,6 +4209,7 @@
SUBDIR += py-pycalendar
SUBDIR += py-pycallgraph
SUBDIR += py-pycerberus
+ SUBDIR += py-pycmd
SUBDIR += py-pycparser
SUBDIR += py-pydasm
SUBDIR += py-pydoop
diff --git a/devel/py-pycmd/Makefile b/devel/py-pycmd/Makefile
new file mode 100644
index 000000000000..2d4f2a40a1ca
--- /dev/null
+++ b/devel/py-pycmd/Makefile
@@ -0,0 +1,24 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pycmd
+PORTVERSION= 1.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Tools for managing/searching Python related files
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py>=1.4.9:${PORTSDIR}/devel/py-py
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pycmd/distinfo b/devel/py-pycmd/distinfo
new file mode 100644
index 000000000000..0d043230d327
--- /dev/null
+++ b/devel/py-pycmd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pycmd-1.2.tar.gz) = adc1976c0106919e9338db20102b91009256dcfec924a66928d7297026f72477
+SIZE (pycmd-1.2.tar.gz) = 12896
diff --git a/devel/py-pycmd/pkg-descr b/devel/py-pycmd/pkg-descr
new file mode 100644
index 000000000000..ffff9ede1640
--- /dev/null
+++ b/devel/py-pycmd/pkg-descr
@@ -0,0 +1,9 @@
+pycmd is a collection of command line tools for helping with Python
+development:
+
+ * py.cleanup: remove .pyc and similar files
+ * py.lookup: find text in recursively found .py files
+ * py.countloc: give LOCs for lines and testlines
+ * py.which: print location of an importable package or module
+
+WWW: https://pypi.python.org/pypi/pycmd