aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-02-07 02:07:33 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-02-07 02:07:33 +0800
commit9d9cd876e91d33e1c95e0c4ff82bfa942b360c56 (patch)
tree7e67640d3783e45905b2df242de7dd41c227706f /devel
parent1faec50bfbcd75cfc8eaeffd98d988948fc69cf4 (diff)
downloadfreebsd-ports-gnome-9d9cd876e91d33e1c95e0c4ff82bfa942b360c56.tar.gz
freebsd-ports-gnome-9d9cd876e91d33e1c95e0c4ff82bfa942b360c56.tar.zst
freebsd-ports-gnome-9d9cd876e91d33e1c95e0c4ff82bfa942b360c56.zip
- Add missing dependency on qt corelib
- Fix dependency on python: require 2.7, fails with python3: bindings/python/qrosspython/cxx/IndirectPythonInterface.cxx:469:12: error: unknown type name 'DL_IMPORT' extern "C" DL_IMPORT(PyTypeObject) PyRange_Type; ^ bindings/python/qrosspython/cxx/IndirectPythonInterface.cxx:469:35: error: expected ';' after top level declarator extern "C" DL_IMPORT(PyTypeObject) PyRange_Type; ^ ; bindings/python/qrosspython/cxx/IndirectPythonInterface.cxx:470:34: error: expected function body after function declarator extern "C" DL_IMPORT(PyObject *) PyRange_New(long, long, long, int); ^ bindings/python/qrosspython/cxx/IndirectPythonInterface.cxx:497:44: error: no member named 'PyExc_MemoryErrorInst' in the global namespace; did you mean '_Exc_MemoryErrorInst'? PyObject * _Exc_MemoryErrorInst() { return ::PyExc_MemoryErrorInst; } ^~~~~~~~~~~~~~~~~~~~~~~ _Exc_MemoryErrorInst ... - Fix dependency on py-sip (use flavors to depend on correct version) - Switch to opt_CMAKE_BOOL Approved by: portmgr blanket
Diffstat (limited to 'devel')
-rw-r--r--devel/qross/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/qross/Makefile b/devel/qross/Makefile
index 675bd411b506..39570225dcac 100644
--- a/devel/qross/Makefile
+++ b/devel/qross/Makefile
@@ -13,7 +13,7 @@ LICENSE= LGPL20+
USES= cmake
USE_LDCONFIG= yes
-USE_QT4= designer gui network xml qmake_build uic_build moc_build \
+USE_QT4= corelib designer gui network xml qmake_build uic_build moc_build \
rcc_build script testlib
USE_GITHUB= yes
GH_ACCOUNT= 0xd34df00d
@@ -24,9 +24,9 @@ WRKSRC_SUBDIR= src
OPTIONS_DEFINE= PYTHON
OPTIONS_SUB= yes
PYTHON_DESC= Python bindings
-PYTHON_CMAKE_ON= -DENABLE_PYTHON:BOOL=true
-PYTHON_CMAKE_OFF= -DENABLE_PYTHON:BOOL=false
-PYTHON_BUILD_DEPENDS= sip:devel/py-sip
+PYTHON_CMAKE_BOOL= ENABLE_PYTHON
+PYTHON_BUILD_DEPENDS= ${PYTHON_INCLUDEDIR}/sip.h:devel/py-sip@${PY_FLAVOR}
+PYTHON_USES= python:2.7
OPTIONS_DEFAULT=PYTHON
post-extract: