aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-11-24 18:15:48 +0800
committersem <sem@FreeBSD.org>2004-11-24 18:15:48 +0800
commitbf9fca16fac61dcb34cceb5cbdbbcb148ce2cafe (patch)
tree73f08de1f947118f3507317037b825766067ca70 /devel
parent418d918cdd0017bcfb2ebc5688dc6bac8bc4df1c (diff)
downloadfreebsd-ports-gnome-bf9fca16fac61dcb34cceb5cbdbbcb148ce2cafe.tar.gz
freebsd-ports-gnome-bf9fca16fac61dcb34cceb5cbdbbcb148ce2cafe.tar.zst
freebsd-ports-gnome-bf9fca16fac61dcb34cceb5cbdbbcb148ce2cafe.zip
New Port: devel/p5-Heap-Simple-XS - An XS implementation
of the Heap::Simple interface PR: ports/73828 Submitted by: Aaron Dalton <aaron(at)daltons.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Heap-Simple-XS/Makefile31
-rw-r--r--devel/p5-Heap-Simple-XS/distinfo2
-rw-r--r--devel/p5-Heap-Simple-XS/pkg-descr8
-rw-r--r--devel/p5-Heap-Simple-XS/pkg-plist9
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c4a97fffd175..a6a86d9e2c7a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -836,6 +836,7 @@
SUBDIR += p5-Heap
SUBDIR += p5-Heap-Simple
SUBDIR += p5-Heap-Simple-Perl
+ SUBDIR += p5-Heap-Simple-XS
SUBDIR += p5-Hook-LexWrap
SUBDIR += p5-IO
SUBDIR += p5-IO-All
diff --git a/devel/p5-Heap-Simple-XS/Makefile b/devel/p5-Heap-Simple-XS/Makefile
new file mode 100644
index 000000000000..57af4bf418bb
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Heap-Simple-XS
+# Date created: 11 November 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Heap-Simple-XS
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Heap
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= An XS implementation of the Heap::Simple interface
+
+BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Heap::Simple::XS.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Heap-Simple-XS/distinfo b/devel/p5-Heap-Simple-XS/distinfo
new file mode 100644
index 000000000000..e8a467c89518
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/distinfo
@@ -0,0 +1,2 @@
+MD5 (Heap-Simple-XS-0.06.tar.gz) = 587d13b368a57bd4f6fc1b4cc117e587
+SIZE (Heap-Simple-XS-0.06.tar.gz) = 55267
diff --git a/devel/p5-Heap-Simple-XS/pkg-descr b/devel/p5-Heap-Simple-XS/pkg-descr
new file mode 100644
index 000000000000..c8ca6c54e664
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/pkg-descr
@@ -0,0 +1,8 @@
+This module provides an XS implementation of the interface described in
+Heap::Simple. Look there for a description.
+
+WWW: http://search.cpan.org/dist/Heap-Simple-XS/
+Author: Ton Hospel <cpan@ton.iguana.be>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Heap-Simple-XS/pkg-plist b/devel/p5-Heap-Simple-XS/pkg-plist
new file mode 100644
index 000000000000..f21a63488854
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Heap/Simple/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS/XS.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Heap/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Heap 2>/dev/null || true