aboutsummaryrefslogtreecommitdiffstats
path: root/dns/djbdns-tools
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-19 19:51:45 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-19 19:51:45 +0800
commit24a4e8487c66ed0effa73afa77e1fcd4e6ca64e8 (patch)
tree725bffbddb0c9c29fd09c9f2266219a35fd66648 /dns/djbdns-tools
parent5307a1d3e3f1d6e60ba532266e133b258db7c4dc (diff)
downloadfreebsd-ports-gnome-24a4e8487c66ed0effa73afa77e1fcd4e6ca64e8.tar.gz
freebsd-ports-gnome-24a4e8487c66ed0effa73afa77e1fcd4e6ca64e8.tar.zst
freebsd-ports-gnome-24a4e8487c66ed0effa73afa77e1fcd4e6ca64e8.zip
Support staging
Diffstat (limited to 'dns/djbdns-tools')
-rw-r--r--dns/djbdns-tools/Makefile12
-rw-r--r--dns/djbdns-tools/pkg-plist10
2 files changed, 16 insertions, 6 deletions
diff --git a/dns/djbdns-tools/Makefile b/dns/djbdns-tools/Makefile
index 8e18957d4b45..7fc8a3892513 100644
--- a/dns/djbdns-tools/Makefile
+++ b/dns/djbdns-tools/Makefile
@@ -19,23 +19,23 @@ CONFLICTS= djbdns-[0-9]*
PROGRAMS= dnsip dnsipq dnsname dnstxt dnsmx dnsfilter \
random-ip dnsqr dnsq dnstrace
SCRIPTS= dnstracesort
-MAN1= dnsfilter.1 dnsip.1 dnsipq.1 dnsmx.1 dnsname.1 \
+
+MANPAGES= dnsfilter.1 dnsip.1 dnsipq.1 dnsmx.1 dnsname.1 \
dnsq.1 dnsqr.1 dnstrace.1 dnstracesort.1 dnstxt.1
ALL_TARGET= it
-NO_STAGE= yes
do-patch:
@${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
@${ECHO_CMD} "${CC} ${STRIP}" > ${WRKSRC}/conf-ld
@${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-home
do-install:
- @${MKDIR} ${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin
@cd ${WRKSRC} && \
- ${INSTALL_PROGRAM} ${PROGRAMS} ${PREFIX}/bin && \
- ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${PROGRAMS} ${STAGEDIR}${PREFIX}/bin && \
+ ${INSTALL_SCRIPT} ${SCRIPTS} ${STAGEDIR}${PREFIX}/bin
@cd ${WRKDIR}/djbdns-man && \
- ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${MANPAGES} ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/dns/djbdns-tools/pkg-plist b/dns/djbdns-tools/pkg-plist
index 77614ad0ad6b..e2160fecde37 100644
--- a/dns/djbdns-tools/pkg-plist
+++ b/dns/djbdns-tools/pkg-plist
@@ -9,3 +9,13 @@ bin/dnstrace
bin/dnstracesort
bin/dnstxt
bin/random-ip
+man/man1/dnsfilter.1.gz
+man/man1/dnsip.1.gz
+man/man1/dnsipq.1.gz
+man/man1/dnsmx.1.gz
+man/man1/dnsname.1.gz
+man/man1/dnsq.1.gz
+man/man1/dnsqr.1.gz
+man/man1/dnstrace.1.gz
+man/man1/dnstracesort.1.gz
+man/man1/dnstxt.1.gz
=626f4a90e89aecdfe791c615f1dacf78f00b9acd'>New port science/gromacsmaho2004-10-195-0/+711 * Update to version 0.99markus2004-10-138-26/+510 * Update to 0.3.3.linimon2004-10-122-4/+3 * Increase USE_GCC to 3.4 for those ports which compile with it.kris2004-09-301-1/+1 * BROKEN on 5.x: Does not compilekris2004-09-191-1/+7 * BROKEN on 5.x: Does not buildkris2004-09-191-1/+7 * Fixed installation on 5.x and 6.x.ru2004-09-061-2/+2 * Update to 0.5.5.linimon2004-09-042-3/+3 * Fix build in presence of x11/nvidia-drivervs2004-09-033-3/+29 * Update to version 0.86krion2004-09-032-5/+5 * o Update to 2.2.2 to unbreak for 5-STABLEmaho2004-09-032-9/+9 * Fix build on 5-STABLEmaho2004-09-031-2/+2 * add py-scipy 0.3ijliao2004-08-267-0/+115 * Update to 1.0.5arved2004-08-224-8/+15 * Add vmd, a molecular visualization program for displaying, animating, andpav2004-08-228-0/+534 * Fix build with gcc 3.4arved2004-08-212-0/+21 * Fix build with gcc 3.4arved2004-08-171-0/+30 * Utilize USE_INC_LIBTOOL_VER and lthack knobskrion2004-08-172-24/+6 * Chase libraries for new math/GiNaC version.krion2004-08-171-1/+1 * USE_INTEL should be WITH_INTELmaho2004-08-161-2/+2 * USE_ICC -> WITH_ICC, and mpi supportmaho2004-08-162-4/+4 * Add Intel C/Fortran support via USE_INTELmaho2004-08-161-2/+2 * Opps forgot to add files/FlexLexer.h takenmaho2004-08-161-0/+186 * Add intel C/C++ compiler supportmaho2004-08-161-4/+22 * Add intel fortran/c/c++ compiler supportmaho2004-08-162-3/+21 * Add abinit, calculates total energy, charge densitymaho2004-08-146-0/+454 * Fix build with gcc-3.4krion2004-08-131-0/+34 * - Poke new libtool infrastructure: use system libtoolpav2004-07-133-14/+3 * Chase libgsl.vs2004-07-122-2/+2 * Update to version 0.84krion2004-07-104-12/+18 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-101-1/+1 * - Update to 1.0.3pav2004-07-092-5/+16 * Deprecate WITHOUT_GETTEXT in favor of WITHOUT_NLS, which is used muchlinimon2004-07-061-1/+1 * Fix build on -CURRENTkris2004-07-021-0/+16 * Autotools cleanup. Remove autoconf257 (259), automake17 (18), andade2004-07-022-2/+2 * Depend on ruby-fftw3arved2004-06-291-0/+2 * - Update to 0.4.5pav2004-06-263-3/+12 * update to 3.2.1maho2004-06-162-3/+3 * - Update to 1.0.3pav2004-06-144-5/+121 * Update to 2.6vs2004-06-063-8/+5 * Don't use Makefile.kde anymoremarkus2004-06-062-6/+2 * - Update to 5.12pav2004-06-057-10906/+11 * - Add missed dependenciespav2004-06-041-1/+4 * - Update to 1.0.2pav2004-06-044-6/+7 * - Fix MASTER_SITESkrion2004-05-311-3/+1 * BROKEN on amd64: Needs to link against shared librarieskris2004-05-301-1/+7 * - Update to 0.4.4pav2004-05-293-14/+4 * - Update to 0.3.2pav2004-05-222-3/+3 * - math/ruby-narray is build dependencypav2004-05-101-2/+3 * Make portlint happy by replacing space to tabmaho2004-05-076-25/+25 * Add kst 0.97.markus2004-04-3011-0/+463 * Update to 0.3.1arved2004-04-203-4/+5 * - Conform to master/slave syntax according to ports/64393pav2004-04-202-2/+6 * Add missing filekris2004-04-172-0/+2 * Back out previous, the distfile needs to be manually fetchedkris2004-04-111-2/+0 * BROKEN: Unfetchablekris2004-04-111-0/+2 * Cram into 80 columns by 24 rows.trevor2004-04-111-2/+1 * - Update to 0.4.3pav2004-04-102-5/+4 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-056-2/+6 * Remove a superfluous RUN_DEPENDS. Hope to unbreak INDEX.thierry2004-04-031-2/+0 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * SIZEify (maintainer timeout)trevor2004-03-316-0/+6 * - Use USE_ICONV knobkrion2004-03-311-2/+2 * Silent distfile change and it has been changedmaho2004-03-301-3/+4 * - Add CONFLICTS between math/netcdf and science/hdf, they both installpav2004-03-253-0/+6 * Add ovt 2.3, the Orbit Visualization Tool.thierry2004-03-245-0/+126 * - Update to 0.4.2pav2004-03-222-3/+3 * - Update to 0.2.5pav2004-03-222-3/+3 * - Update to version 3.5.1krion2004-03-2114-228/+32 * A Density functional software. This software has a unique designmaho2004-03-209-0/+358 * 1) add documentsmaho2004-03-194-18/+41 * The PSI3 suite of quantum chemical programs is designed for efficient,maho2004-03-199-0/+687 * SIZEifymaho2004-03-194-0/+7 * SIZEify.trevor2004-03-183-0/+3 * - cdcl is a build dependencypav2004-03-171-3/+4 * Chase library bump of libSDL-1.1 for all ports which were dependingedwin2004-03-161-1/+1 * Update to 0.5.4.knu2004-03-152-3/+3 * Add gave, a gtk+ based grid data analyser and viewer written in Ruby.pav2004-03-155-0/+44 * Add ruby-gphys, a multi-purpose class to handle gridded physicalpav2004-03-155-0/+104 * - Update to 1.4.0pav2004-03-143-11/+4 * - Fixup packagepav2004-03-141-0/+3 * - Update gtk patch to version 5pav2004-03-143-3/+6 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-148-8/+7 * - Update to 0.4.1pav2004-03-123-6/+6 * - Update to 0.2.4pav2004-03-123-4/+5 * Clean up this portmaho2004-03-112-9/+27 * BROKEN on amd64 and alpha: Does not compilekris2004-03-091-1/+7 * - Attempt to fix build on Sparcpav2004-03-094-14/+8 * USE MASTERDIR when include Makefilemaho2004-03-081-1/+1 * BROKEN on sparc64: Configure fails.kris2004-03-072-2/+14 * BROKEN on !i386 and !alpha: Does not compilekris2004-03-071-1/+7 * 1) some cleanups and enhancementsmaho2004-03-073-4/+23 * BROKEN on alpha: Does not compilekris2004-03-051-1/+7 * - Update to version 1.3krion2004-03-053-13/+83 * - Update to 1.100.2pav2004-03-044-21/+38 * - Fix packaging of slave portspav2004-03-042-0/+6 * set CATEGORIES equal to science/hdf5, fixing PKGORIGINeik2004-02-291-1/+1 * Add ruby-dcl, a ruby interface to DCL, a scienific graphical library.pav2004-02-286-0/+314 * update to 1.01 and unbreakmaho2004-02-283-47/+44 * - Make MAINTAINER and COMMENT fields overridable by slave portpav2004-02-281-2/+2 * Add cdcl-gtk, a slave port for science/cdcl with enabled Gtk support.pav2004-02-282-0/+14 * Add cdcl, a scientific graphic library for geosciencepav2004-02-285-0/+675 * Chase repomove graphics/hdf* -> science/hdf*pav2004-02-261-1/+1 * Unhook hdf* ports in graphics, hook them in science.pav2004-02-261-0/+2 * After repocopy from graphics/hdf5,pav2004-02-266-88/+88 * - Update to 1.0.1pav2004-02-253-442/+564 * This is broken on 4.x as well.kris2004-02-231-7/+3 * BROKEN: Checksum mismatchkris2004-02-221-0/+2 * BROKEN on 5.x: does not compilekris2004-02-181-1/+7 * Update to 0.5.3knu2004-02-173-4/+6 * - Fix build on AMD64krion2004-02-081-1/+3 * fix build on currentoliver2004-02-076-30/+104 * - Fix build on -currentkrion2004-02-064-14/+42 * BROKEN: Does not compile on 5.xkris2004-02-052-2/+14 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-0418-2/+18 * Gramps (Genealogical Research and Analysis Management Programming System)pav2004-02-015-0/+502 * - Remove local mastersite now Savannah is backpav2004-01-301-5/+2 * SIZEify.trevor2004-01-3015-0/+15 * SIZEify.trevor2004-01-292-0/+2 * - Update to version 0.7.0krion2004-01-273-57/+66 * - Chase libraries for new math/GiNaC versionkrion2004-01-231-2/+2 * Use the CPIO macro defined in bsd.port.mk.trevor2004-01-221-1/+1 * - Put distfile on MASTER_SITE_LOCAL until Savannah is restoredpav2004-01-081-2/+5 * - Update to version 0.81krion2004-01-065-22/+42 * - Update to 0.4.0pav2004-01-043-3/+3 * Update to 2.2.1maho2003-12-284-30/+234 * - Use canonical form (ports@FreeBSD.org) in MAINTAINER linesergei2003-12-211-1/+1 * - Update to 0.3.90pav2003-12-135-36/+12 * USE_MESA -> USE_GLfjoe2003-12-101-1/+1 * - Make it do actually something useful.pav2003-12-071-4/+9 * - Fix build on 5.xpav2003-12-074-22/+54 * - Update to version 2.5krion2003-11-223-8/+8 * Update maintainer field with my FreeBSD.org address.pav2003-11-142-2/+2 * Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.trevor2003-11-131-1/+2 * upgrade to 1.6.1ijliao2003-11-1310-20/+184 * Forgot to remove EXAMPLEDIRmaho2003-11-101-0/+1 * Remove a patch forgotten in the last commit.marcus2003-11-091-64/+0 * Update to 0.3.6.marcus2003-11-095-4/+33 * . Welcome felt to the science category.glewis2003-11-082-1/+2 * - Chase libraries for new math/GiNaC versionkrion2003-11-071-2/+2 * Chase the gcu shared lib version.marcus2003-11-031-1/+2 * Update to 0.2.0, the first stable release.marcus2003-11-033-12/+7 * upgrade to 0.6.0ijliao2003-10-283-6/+21 * utilize SITE_PERLijliao2003-10-242-6/+5 * add kmovisto 0.5.1ijliao2003-10-245-0/+68 * Before committing the previous BROKEN changes I carefully checked the statuskris2003-10-161-7/+1 * BROKEN on 5.x: does not compilekris2003-10-161-1/+7 * Fix configure by remove -lcipher.osa2003-10-132-2/+4 * - Fix build on 4-stablekrion2003-10-113-8/+41 * Fix CONFIGURE_ENV, this is passed as-is to the shell.maho2003-10-081-2/+2 * Add INSTALLS_SHLIB to the Makefileedwin2003-10-061-0/+2 * Remove #maho2003-10-041-1/+1 * Update to up-to-date developer versionmaho2003-10-043-9/+33 * Honor CFLAGSmaho2003-10-041-1/+1 * a) add support for EMF formatmaho2003-10-041-6/+4 * Update to 2.1.5maho2003-10-042-4/+4 * Chase up new MASTER_SITE_SAVANNAH.edwin2003-10-032-2/+4 * Make portlint(1) happy by changing strip to ${STRIP_CMD}osa2003-09-242-2/+2 * New port: science/at Acoustic ToolBoxedwin2003-09-086-0/+366 * Fix very stupid error.maho2003-09-041-1/+4 * 1) takeover maintainershipmaho2003-09-041-2/+4 * - don't clobber any given LDFLAGSdinoex2003-08-312-2/+2 * Fixed build dependencymaho2003-08-301-2/+2 * Update to 0.3.5.marcus2003-08-293-2/+66 * Update to 0.1.7.marcus2003-08-293-3/+88 * Update to CAD/feltedwin2003-08-255-9/+741 * Fix `fails to patch'maho2003-08-191-13/+0 * - Don't hardcode python version on Makefile and pkg-plist.perky2003-08-184-18/+22 * Fix configure failure (autoconf257 is required)maho2003-08-121-1/+1 * Fix build on 4-STABLEmaho2003-08-081-21/+25 * Update to 2.1.4maho2003-08-034-1715/+1747 * Fix build on gcc-3.3.xmaho2003-08-022-0/+24 * Chase the GtkGLExt shared lib version.marcus2003-07-311-1/+1 * Add bash for BUILD_DEPENDSmaho2003-07-281-0/+1 * Unbreak by clean-ups.maho2003-07-272-11/+8 * Add a missing dependency on libgnomeui.marcus2003-07-271-2/+2 * Add a dependency on gnometarget to quiet a configure warning.marcus2003-07-271-1/+1 * Drop maintainership of science/mmtkdaichi2003-07-251-1/+1 * Added a Numerical Hartree-Fock Program for Diatomic Molecules.maho2003-07-249-0/+496 * Comment out chemtool-devel, which provides a duplicate chemtool-1.6 versionkris2003-07-231-1/+1 * Update to version 0.77.4maho2003-07-213-15/+2 * Update to 1.6 and some clean-up.maho2003-07-217-104/+63 * Fix build on -CURRENT (gcc-3.3)osa2003-07-201-0/+13 * get rid of libgnugetopt dependency for -CURRENT,sf2003-07-14