aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-11-17 07:59:19 +0800
committerwxs <wxs@FreeBSD.org>2008-11-17 07:59:19 +0800
commit93fdfa3d93400c476ad68b6197b07d5ba3a09fd5 (patch)
treefc1bbfae1e3df3b6457aa3ef2a029733204bc1e4 /editors
parent15ae021fad1d566bac61db07605cf2428dda2b34 (diff)
downloadfreebsd-ports-gnome-93fdfa3d93400c476ad68b6197b07d5ba3a09fd5.tar.gz
freebsd-ports-gnome-93fdfa3d93400c476ad68b6197b07d5ba3a09fd5.tar.zst
freebsd-ports-gnome-93fdfa3d93400c476ad68b6197b07d5ba3a09fd5.zip
This is the development version of nano:
nano is a small, free and friendly editor which aims to replace Pico, the default editor included in the non-free Pine package. Rather than just copying Pico's look and feel, nano also implements some missing (or disabled by default) features in Pico, such as "search and replace" and "goto line number". PR: ports/128060 Submitted by: Eitan Adler <EitanAdlerList@gmail.com>
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/nano-devel/Makefile59
-rw-r--r--editors/nano-devel/distinfo3
-rw-r--r--editors/nano-devel/files/patch-doc_man_Makefile.in20
-rw-r--r--editors/nano-devel/files/patch-doc_man_fr_Makefile.in20
-rw-r--r--editors/nano-devel/files/patch-doc_man_nano.114
-rw-r--r--editors/nano-devel/files/patch-doc_man_nanorc.515
-rw-r--r--editors/nano-devel/pkg-descr9
-rw-r--r--editors/nano-devel/pkg-plist66
9 files changed, 207 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index a068fb5a689b..7daf57c1e467 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -106,6 +106,7 @@
SUBDIR += mousepad
SUBDIR += mp
SUBDIR += nano
+ SUBDIR += nano-devel
SUBDIR += ne
SUBDIR += nedit
SUBDIR += nvi-devel
diff --git a/editors/nano-devel/Makefile b/editors/nano-devel/Makefile
new file mode 100644
index 000000000000..13123870b7e6
--- /dev/null
+++ b/editors/nano-devel/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: nano-devel
+# Date created: 13 November 2008
+# Whom: Eitan Adler <EitanAdlerList@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nano-devel
+PORTVERSION= 2.1.7
+CATEGORIES= editors
+MASTER_SITES= http://www.nano-editor.org/dist/v2.1/ \
+ http://www.ewtoo.org/~astyanax/nano/dist/v2.1/
+DISTNAME= nano-${PORTVERSION}
+
+MAINTAINER= EitanAdlerList@gmail.com
+COMMENT= Nano's ANOther editor, an enhanced free Pico clone
+
+CONFLICTS= nano-2*
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-all --enable-rc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+MANLANG= "" fr
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+INFO= nano
+MAN1= nano.1 rnano.1
+MAN5= nanorc.5
+
+.include <bsd.port.pre.mk>
+
+# requires wide character curses
+.if (${OSVERSION} < 602107) || (${OSVERSION} >= 700000 && ${OSVERSION} < 700033)
+CONFIGURE_ARGS+=--disable-utf8
+.else
+CONFIGURE_ARGS+=--enable-utf8
+.endif
+
+post-build:
+ cd ${WRKSRC}/doc/man; ${REINPLACE_CMD} \
+ -e 's:SYSCONFDIR:${PREFIX}/etc:g' \
+ -e 's:EXAMPLESDIR:${EXAMPLESDIR}:g' \
+ ${MAN1} ${MAN5} ${WRKSRC}/doc/texinfo/${INFO:=.info}
+ ${REINPLACE_CMD} -e 's/\\</[[:<:]]/g' -e 's/\\>/[[:>:]]/g' \
+ ${WRKSRC}/doc/syntax/*.nanorc
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/nanorc.sample ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>
diff --git a/editors/nano-devel/distinfo b/editors/nano-devel/distinfo
new file mode 100644
index 000000000000..2f5008e90861
--- /dev/null
+++ b/editors/nano-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (nano-2.1.7.tar.gz) = 4eb4fcd015e3c09e3a119250286bc67f
+SHA256 (nano-2.1.7.tar.gz) = b1d2cd011af513c072e2a76eeaadbc4200c575bb8113cbeac57d0680e8a6d81f
+SIZE (nano-2.1.7.tar.gz) = 1468710
diff --git a/editors/nano-devel/files/patch-doc_man_Makefile.in b/editors/nano-devel/files/patch-doc_man_Makefile.in
new file mode 100644
index 000000000000..d9b01eacc922
--- /dev/null
+++ b/editors/nano-devel/files/patch-doc_man_Makefile.in
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- doc/man/Makefile.in.orig
++++ doc/man/Makefile.in
+@@ -592,11 +592,11 @@
+
+
+ nano.1.html: nano.1
+- groff -t -mandoc -Thtml < $< > $@
++ groff -t -mandoc -Thtml < $? > $@
+ nanorc.5.html: nanorc.5
+- groff -t -mandoc -Thtml < $< > $@
++ groff -t -mandoc -Thtml < $? > $@
+ rnano.1.html: rnano.1
+- groff -t -mandoc -Thtml < $< > $@
++ groff -t -mandoc -Thtml < $? > $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/editors/nano-devel/files/patch-doc_man_fr_Makefile.in b/editors/nano-devel/files/patch-doc_man_fr_Makefile.in
new file mode 100644
index 000000000000..7a8b96fe6880
--- /dev/null
+++ b/editors/nano-devel/files/patch-doc_man_fr_Makefile.in
@@ -0,0 +1,20 @@
+
+$FreeBSD: /tmp/pcvs/ports/editors/nano-devel/files/Attic/patch-doc_man_fr_Makefile.in,v 1.1 2008-11-16 23:59:19 wxs Exp $
+
+--- doc/man/fr/Makefile.in.orig
++++ doc/man/fr/Makefile.in
+@@ -434,11 +434,11 @@
+
+
+ nano.1.html: nano.1
+- groff -t -mandoc -Thtml < $< > $@
++ groff -t -mandoc -Thtml < $? > $@
+ nanorc.5.html: nanorc.5
+- groff -t -mandoc -Thtml < $< > $@
++ groff -t -mandoc -Thtml < $? > $@
+ rnano.1.html: rnano.1
+- groff -t -mandoc -Thtml < $< > $@
++ groff -t -mandoc -Thtml < $? > $@
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/editors/nano-devel/files/patch-doc_man_nano.1 b/editors/nano-devel/files/patch-doc_man_nano.1
new file mode 100644
index 000000000000..83b29674576e
--- /dev/null
+++ b/editors/nano-devel/files/patch-doc_man_nano.1
@@ -0,0 +1,14 @@
+
+$FreeBSD: /tmp/pcvs/ports/editors/nano-devel/files/patch-doc_man_nano.1,v 1.1 2008-11-16 23:59:19 wxs Exp $
+
+--- doc/man/nano.1.orig
++++ doc/man/nano.1
+@@ -224,8 +224,6 @@
+ .PD 0
+ .TP
+ \fBnanorc\fP(5)
+-.PP
+-\fI/usr/share/doc/nano/\fP (or equivalent on your system)
+
+ .SH AUTHOR
+ Chris Allegretta <chrisa@asty.org>, et al (see \fIAUTHORS\fP and
diff --git a/editors/nano-devel/files/patch-doc_man_nanorc.5 b/editors/nano-devel/files/patch-doc_man_nanorc.5
new file mode 100644
index 000000000000..fe67dd7377bf
--- /dev/null
+++ b/editors/nano-devel/files/patch-doc_man_nanorc.5
@@ -0,0 +1,15 @@
+
+$FreeBSD: /tmp/pcvs/ports/editors/nano-devel/files/patch-doc_man_nanorc.5,v 1.1 2008-11-16 23:59:19 wxs Exp $
+
+--- doc/man/nanorc.5.orig
++++ doc/man/nanorc.5
+@@ -250,8 +250,7 @@
+ .TP
+ \fBnano\fP(1)
+ .PP
+-\fI/usr/share/doc/nano/examples/nanorc.sample\fP (or equivalent on your
+-system)
++\fIEXAMPLESDIR/nanorc.sample\fP
+ .SH AUTHOR
+ Chris Allegretta <chrisa@asty.org>, et al (see \fIAUTHORS\fP and
+ \fITHANKS\fP for details). This manual page was originally written by
diff --git a/editors/nano-devel/pkg-descr b/editors/nano-devel/pkg-descr
new file mode 100644
index 000000000000..eadc32c90ea3
--- /dev/null
+++ b/editors/nano-devel/pkg-descr
@@ -0,0 +1,9 @@
+This is the development version of nano:
+
+nano is a small, free and friendly editor which aims to replace
+Pico, the default editor included in the non-free Pine package.
+Rather than just copying Pico's look and feel, nano also implements
+some missing (or disabled by default) features in Pico, such as
+"search and replace" and "goto line number".
+
+WWW: http://www.nano-editor.org/
diff --git a/editors/nano-devel/pkg-plist b/editors/nano-devel/pkg-plist
new file mode 100644
index 000000000000..8514e3b5be4f
--- /dev/null
+++ b/editors/nano-devel/pkg-plist
@@ -0,0 +1,66 @@
+@comment $FreeBSD: /tmp/pcvs/ports/editors/nano-devel/pkg-plist,v 1.1 2008-11-16 23:59:19 wxs Exp $
+bin/nano
+bin/rnano
+%%NLS%%share/locale/bg/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/da/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/de/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/es/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/id/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/it/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/nano.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/nano.mo
+%%EXAMPLESDIR%%/nanorc.sample
+share/nano/awk.nanorc
+share/nano/fortran.nanorc
+share/nano/xml.nanorc
+share/nano/php.nanorc
+share/nano/tcl.nanorc
+share/nano/ocaml.nanorc
+share/nano/debian.nanorc
+share/nano/css.nanorc
+share/nano/objc.nanorc
+share/nano/gentoo.nanorc
+share/nano/asm.nanorc
+share/nano/c.nanorc
+share/nano/groff.nanorc
+share/nano/html.nanorc
+share/nano/java.nanorc
+share/nano/man.nanorc
+share/nano/mutt.nanorc
+share/nano/nanorc.nanorc
+share/nano/patch.nanorc
+share/nano/perl.nanorc
+share/nano/pov.nanorc
+share/nano/python.nanorc
+share/nano/ruby.nanorc
+share/nano/sh.nanorc
+share/nano/tex.nanorc
+@dirrm share/nano
+@dirrm %%EXAMPLESDIR%%
+%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/rw
+%%NLS%%@dirrmtry man/fr/man5
+%%NLS%%@dirrmtry man/fr/man1
+%%NLS%%@dirrmtry man/fr