aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/jftpgw/Makefile
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2002-04-12 04:12:21 +0800
committerStefan Eßer <se@FreeBSD.org>2002-04-12 04:12:21 +0800
commitdaaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc (patch)
tree253adb1f979d41b485e6ffb1db6dae04f4618708 /ftp/jftpgw/Makefile
parent4ba9a9ad70fd0a27c31f6f1d432a3147c37ac532 (diff)
downloadfreebsd-ports-gnome-daaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc.tar.gz
freebsd-ports-gnome-daaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc.tar.zst
freebsd-ports-gnome-daaaf6dd499cd03c9f97a79ff4f6e5c866dbe4dc.zip
Upgrade to release 0.13.1.
Seems that privileges are dropped in a way, that restricts writing of the PID file to driectories that can be written into by the UID the process is running under (i.e. nobody). This will be fixed later ...
Diffstat (limited to 'ftp/jftpgw/Makefile')
-rw-r--r--ftp/jftpgw/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/ftp/jftpgw/Makefile b/ftp/jftpgw/Makefile
index 0e3b5a0f57bf..af0527c65b7a 100644
--- a/ftp/jftpgw/Makefile
+++ b/ftp/jftpgw/Makefile
@@ -6,22 +6,23 @@
#
PORTNAME= jftpgw
-PORTVERSION= 0.0.13j
+PORTVERSION= 0.13.1
CATEGORIES= ftp
MASTER_SITES= http://www.mcknight.de/jftpgw/
-DISTNAME= jftpgw-0.13.beta.j
MAINTAINER= se@FreeBSD.org
+USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-confpath=${PREFIX}/etc \
- --with-logpath=/var/log \
+CONFIGURE_ARGS= --with-logpath=/var/log \
--enable-crypt \
--enable-sftp
+MAN1= jftpgw.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/jftpgw ${PREFIX}/sbin/
${INSTALL_DATA} ${WRKSRC}/jftpgw.conf.sample ${PREFIX}/etc/
+ ${INSTALL_MAN} ${WRKSRC}/jftpgw.1 ${PREFIX}/man/man1/
@${SED} -e 's:@PREFIX@:${PREFIX}:g' \
${FILESDIR}/jftpgw.sh.in > ${WRKDIR}/jftpgw.sh
${INSTALL_SCRIPT} ${WRKDIR}/jftpgw.sh ${PREFIX}/etc/rc.d