aboutsummaryrefslogtreecommitdiffstats
path: root/games/gnomoku
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-17 00:02:48 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-17 00:02:48 +0800
commit30d071bbb7f95a420d9138e0d57b5917b06f45f8 (patch)
tree898d5c3fc197a3c30f37d8c78f9e94cb73a13a4f /games/gnomoku
parent70db90a2d52b1d1343518fbc8f2f138ecb977325 (diff)
downloadfreebsd-ports-gnome-30d071bbb7f95a420d9138e0d57b5917b06f45f8.tar.gz
freebsd-ports-gnome-30d071bbb7f95a420d9138e0d57b5917b06f45f8.tar.zst
freebsd-ports-gnome-30d071bbb7f95a420d9138e0d57b5917b06f45f8.zip
Use USE_GNOMENG.
Diffstat (limited to 'games/gnomoku')
-rw-r--r--games/gnomoku/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/games/gnomoku/Makefile b/games/gnomoku/Makefile
index 193ece64553f..dce271b99dfa 100644
--- a/games/gnomoku/Makefile
+++ b/games/gnomoku/Makefile
@@ -16,17 +16,15 @@ MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= gnomemm.9:${PORTSDIR}/x11-toolkits/gnome--
USE_X_PREFIX= yes
-#USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-fpermissive -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>