aboutsummaryrefslogtreecommitdiffstats
path: root/games/noegnud-nethack/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-18 23:05:06 +0800
committerpawel <pawel@FreeBSD.org>2014-04-18 23:05:06 +0800
commitc49d94d08a85e2f3c0166ed46ba20b8c3a1795a8 (patch)
tree264dd5727c8137b0c82f0e5a702f7a6d6e278e5c /games/noegnud-nethack/Makefile
parentc21ef89d9f3aca44c11d0c016694a8aac63e9934 (diff)
downloadfreebsd-ports-gnome-c49d94d08a85e2f3c0166ed46ba20b8c3a1795a8.tar.gz
freebsd-ports-gnome-c49d94d08a85e2f3c0166ed46ba20b8c3a1795a8.tar.zst
freebsd-ports-gnome-c49d94d08a85e2f3c0166ed46ba20b8c3a1795a8.zip
- Fix build on 10+ (use gmake during build)
- Add staging support - Convert to USES=tar:bzip2 - Remove Author tag from pkg-descr, info available on homepage MFH: 2014Q2
Diffstat (limited to 'games/noegnud-nethack/Makefile')
-rw-r--r--games/noegnud-nethack/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/noegnud-nethack/Makefile b/games/noegnud-nethack/Makefile
index a02fea478e97..b9c7f03b216a 100644
--- a/games/noegnud-nethack/Makefile
+++ b/games/noegnud-nethack/Makefile
@@ -18,18 +18,16 @@ COMMENT= The noeGNUd UI for the vanilla Nethack
RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
-USES= bison gmake
+USES= bison gmake tar:bzip2
USE_GL= yes
WANT_SDL= yes
USE_SDL= sdl image mixer
-USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
ALL_TARGET= nh343
INSTALL_TARGET= install_nh343
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-everything::
@@ -46,6 +44,12 @@ post-extract:
post-patch:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.3)
@(${PATCH} ${PATCH_ARGS} < ${FILESDIR}/noegnud-nethack.patch)
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ -e 's|make|${MAKE_CMD}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E -e 's,ch(grp|own),true,' \
+ -e '/(^VARDIR|ln -s|sed)/! s,(GAME|SHELL|VAR)DIR),DESTDIR)$$(&,g' \
+ -e '/ln -s/ s,SHELLDIR,DESTDIR)$$(&,2' \
+ ${WRKSRC}/${NOEGNUDVERSION}-nethack-3.4.3/sys/unix/Makefile.top
do-configure:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.3/Makefile)