aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-04-15 21:54:43 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-04-15 21:54:43 +0800
commit424d3f230730505ead76f74f48b1760b1ff8578f (patch)
treebd3620ca9c882e497bc2201c352d585158ccf5c5 /games
parent1fbff5979d13935b0cb471df3e35910c74ce1b00 (diff)
downloadfreebsd-ports-gnome-424d3f230730505ead76f74f48b1760b1ff8578f.tar.gz
freebsd-ports-gnome-424d3f230730505ead76f74f48b1760b1ff8578f.tar.zst
freebsd-ports-gnome-424d3f230730505ead76f74f48b1760b1ff8578f.zip
- Fix build on < 10.x
- Respect CC Approved by: portmgr blanket
Diffstat (limited to 'games')
-rw-r--r--games/tomenet/Makefile6
-rw-r--r--games/tomenet/files/patch-makefile2
2 files changed, 7 insertions, 1 deletions
diff --git a/games/tomenet/Makefile b/games/tomenet/Makefile
index c2fc931d4ec5..cd4515733ec6 100644
--- a/games/tomenet/Makefile
+++ b/games/tomenet/Makefile
@@ -31,6 +31,12 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
+.if ${OSVERSION} < 1000000
+LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+CFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+.endif
+
post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/tomenet/files/patch-makefile b/games/tomenet/files/patch-makefile
index c88ac7f509b2..ca184a625d1f 100644
--- a/games/tomenet/files/patch-makefile
+++ b/games/tomenet/files/patch-makefile
@@ -5,7 +5,7 @@
# This is my compiler of choice, it seems to work most everywhere
#
-CC = gcc
-+CC = cc
++CC ?= cc
# For allowing #if..#else..#endif constructs in LUA files - C. Blue
# Note: The flags must contain