aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xmorph/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-04-24 19:29:32 +0800
committererwin <erwin@FreeBSD.org>2006-04-24 19:29:32 +0800
commit45c878352a998ae59987423a4c75b2fdd0b339df (patch)
tree388e72f2867555f17bf99789613be99cbf7517b1 /graphics/xmorph/Makefile
parentd4f25e669e899b90869e5e06ef0739bd4317585e (diff)
downloadfreebsd-ports-gnome-45c878352a998ae59987423a4c75b2fdd0b339df.tar.gz
freebsd-ports-gnome-45c878352a998ae59987423a4c75b2fdd0b339df.tar.zst
freebsd-ports-gnome-45c878352a998ae59987423a4c75b2fdd0b339df.zip
Update to 2006.03.04
PR: 96216 Submitted by: ports fury
Diffstat (limited to 'graphics/xmorph/Makefile')
-rw-r--r--graphics/xmorph/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/graphics/xmorph/Makefile b/graphics/xmorph/Makefile
index 37a75798c840..2fc36c112c78 100644
--- a/graphics/xmorph/Makefile
+++ b/graphics/xmorph/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmorph
-PORTVERSION= 2004.01.10
-PORTREVISION= 2
+PORTVERSION= 2006.03.04
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,16 +15,20 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= A digital image warping program
-WRKSRC= ${WRKDIR}/${PORTNAME}-current
+LIB_DEPENDS= fftw3.3:${PORTSDIR}/math/fftw3
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
CONFLICTS= libmorph*
USE_X_PREFIX= yes
WANT_GNOME= yes
-USE_GNOME= gnometarget lthack
+USE_GNOME= gnometarget
+USE_GCC= 3.4+
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --without-waili
INSTALLS_SHLIB= yes
MAN1= xmorph.1
@@ -33,6 +36,10 @@ INFO= xmorph
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502114
+CFLAGS+= -Dround=rint
+.endif
+
# XXX Seems that gtkmorph.1 is always installed
MAN1+= gtkmorph.1
.if ${HAVE_GNOME:Mgtk20}!=""
@@ -53,6 +60,9 @@ PLIST_SUB+= NLS=""
post-extract:
@${RM} -f ${WRKSRC}/doc/*.info*
+post-patch:
+ @${REINPLACE_CMD} -e 's|^LDFLAGS=|#LDFLAGS=|g' ${WRKSRC}/configure
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}