aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-03-15 02:18:40 +0800
committerChris Rees <crees@FreeBSD.org>2012-03-15 02:18:40 +0800
commit25685bc9aeb3e06643e2a5bd93495783a50de474 (patch)
tree503f4256c2e8c016480844e77c338255851edcc7 /graphics
parentdff2100620c325de88221810d9d04548e21472ee (diff)
downloadfreebsd-ports-gnome-25685bc9aeb3e06643e2a5bd93495783a50de474.tar.gz
freebsd-ports-gnome-25685bc9aeb3e06643e2a5bd93495783a50de474.tar.zst
freebsd-ports-gnome-25685bc9aeb3e06643e2a5bd93495783a50de474.zip
Add OPTION for --with-pic
PR: ports/164906 Submitted by: Martin Dieringer <martin.dieringer@gmx.de> Approved by: bytestore@yandex.ru (maintainer) Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libjpeg-turbo/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index fdbcc3cdb75b..84c0a2de1291 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -32,4 +32,12 @@ PLIST_SUB= SOVERSION=${SOVERSION}
# chase graphics/jpeg
SOVERSION= 11
+OPTIONS+= PIC "Static library with PIC (required for VirtualGL)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PIC)
+CONFIGURE_ARGS+=--with-pic
+.endif
+
.include <bsd.port.mk>